summaryrefslogtreecommitdiff
path: root/plugins/fullscreen/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/fullscreen/meson.build')
-rw-r--r--plugins/fullscreen/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/plugins/fullscreen/meson.build b/plugins/fullscreen/meson.build
new file mode 100644
index 0000000..960a09e
--- /dev/null
+++ b/plugins/fullscreen/meson.build
@@ -0,0 +1,27 @@
+desktopfile = configure_file(input: 'fullscreen.plugin.desktop.in.in', configuration: pkg_info, output: 'fullscreen.plugin.desktop.in')
+if get_option('nls')
+ i18n.merge_file(
+ input: desktopfile,
+ output: 'fullscreen.plugin',
+ install: true,
+ install_dir: pluginsdir,
+ type: 'desktop',
+ po_dir: po_dir,
+ )
+else
+ install_data(desktopfile, install_dir: pluginsdir, rename: ['fullscreen.plugin'])
+endif
+
+shared_library(
+ 'fullscreen',
+ sources: [
+ 'eom-fullscreen-plugin.h',
+ 'eom-fullscreen-plugin.c',
+ ],
+ c_args: plugins_c_args,
+ dependencies: all_deps,
+ include_directories: [top_inc, src_inc],
+ link_with: [eom_links],
+ install: true,
+ install_dir: pluginsdir
+)