summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 20:53:10 -0300
committerPerberos <[email protected]>2011-12-01 20:53:10 -0300
commit916e2eafe251b44f9d0339282f5d00723899caec (patch)
treed650ca8c97d834499ca107a2a59a41c86c1fc4a9 /test/Makefile.am
downloadlibmatekbd-916e2eafe251b44f9d0339282f5d00723899caec.tar.bz2
libmatekbd-916e2eafe251b44f9d0339282f5d00723899caec.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..148a3dd
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,25 @@
+noinst_PROGRAMS = matekbd-indicator-test \
+ matekbd-keyboard-drawing-test \
+ matekbd-status-test
+
+common_CFLAGS = $(WARN_CFLAGS) -I$(top_srcdir) -Wall \
+ $(GTK_CFLAGS) \
+ $(LIBXKLAVIER_CFLAGS) \
+ -DMATELOCALEDIR="\"$(datadir)/locale\""
+
+common_LDFLAGS = $(GTK_LIBS) \
+ $(LIBXKLAVIER_LIBS) \
+ $(top_builddir)/libmatekbd/libmatekbd.la \
+ $(top_builddir)/libmatekbd/libmatekbdui.la
+
+matekbd_indicator_test_CFLAGS=$(common_CFLAGS)
+
+matekbd_indicator_test_LDFLAGS=$(common_LDFLAGS)
+
+matekbd_keyboard_drawing_test_CFLAGS=$(common_CFLAGS)
+
+matekbd_keyboard_drawing_test_LDFLAGS=$(common_LDFLAGS)
+
+matekbd_status_test_CFLAGS=$(common_CFLAGS)
+
+matekbd_status_test_LDFLAGS=$(common_LDFLAGS)