summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-12-13 11:27:19 +0300
committermonsta <[email protected]>2016-12-13 11:27:19 +0300
commitb4ddcc1d1f7635d19db4b015a54b45dca63e2c88 (patch)
tree97697bcc3131c21603cfda03a65fa3d22ef7b801 /configure.ac
parentbfa1740cce3269373d055b5fb9f5f6867d63d0cb (diff)
downloadlibmateweather-b4ddcc1d1f7635d19db4b015a54b45dca63e2c88.tar.bz2
libmateweather-b4ddcc1d1f7635d19db4b015a54b45dca63e2c88.tar.xz
drop Python bindings and --enable-python build option
it requires PyGTK so won't even build with GTK+3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 64e5609..9bcb32e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,24 +167,6 @@ fi
AC_DEFINE_UNQUOTED(ZONEINFO_DIR, "$ZONEINFO_DIR", [zoneinfo directory])
dnl ***************************************************************************
-dnl *** Python bindings
-dnl ***************************************************************************
-AC_ARG_ENABLE(python,
- [AC_HELP_STRING([--enable-python],
- [Build libmateweather python bindings])],
- [enable_python=$enableval],
- [enable_python=no])
-if test "$enable_python" = "yes"; then
- AM_PATH_PYTHON()
- AM_CHECK_PYTHON_HEADERS(,enable_python=no)
- PKG_CHECK_MODULES(PYGOBJECT, pygobject-2.0)
- pygtk_defsdir=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
- PYGTK_DEFS="$pygtk_defsdir/gtk.defs"
- AC_SUBST(PYGTK_DEFS)
-fi
-AM_CONDITIONAL(BUILD_PYTHON, test "x$enable_python" = "xyes")
-
-dnl ***************************************************************************
dnl *** Honour aclocal flags ***
dnl ***************************************************************************
ACLOCAL_AMFLAGS="\${ACLOCAL_FLAGS}"
@@ -194,7 +176,6 @@ AC_SUBST(VERSION)
AC_SUBST(PACKAGE)
AC_SUBST(DATADIR)
AC_SUBST(LIBDIR)
-AC_SUBST(PYTHONDIR)
AC_SUBST(GLADEDIR)
##################################################
@@ -215,7 +196,6 @@ libmateweather/mateweather.pc
libmateweather/mateweather-uninstalled.pc
libmateweather/org.mate.weather.gschema.xml
data/Makefile
-python/Makefile
icons/Makefile
])
AC_OUTPUT
@@ -234,7 +214,6 @@ libmateweather-$VERSION configure summary:
Prefix: ${prefix}
Source code location: ${srcdir}
Compiler: ${CC}
- Python bindings: ${enable_python}
Locations.xml translations: ${LOCATIONS_XML_TRANSLATIONS}
Locations.xml compression: ${enable_locations_compression}
Gtk+ version: ${GTK_API_VERSION}