summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-10-01 22:52:14 +0200
committerStefano Karapetsas <[email protected]>2012-10-01 22:52:14 +0200
commit7f595187a140a45ee5ba2fc2b9c068b46d829f79 (patch)
tree0ed7bc81a4403d5b854953e1e6c46a8231fd1a2e /configure.in
parent2c0d59c170ac3ef987d21599cfac7c909e8fe729 (diff)
downloadmarco-7f595187a140a45ee5ba2fc2b9c068b46d829f79.tar.bz2
marco-7f595187a140a45ee5ba2fc2b9c068b46d829f79.tar.xz
migrate to gsettings
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 5 insertions, 32 deletions
diff --git a/configure.in b/configure.in
index 9fe68600..56218e47 100644
--- a/configure.in
+++ b/configure.in
@@ -1,10 +1,10 @@
AC_PREREQ(2.50)
m4_define([marco_major_version], [1])
-m4_define([marco_minor_version], [4])
+m4_define([marco_minor_version], [0])
# Fibonacci sequence for micro version numbering:
# 0, 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, 377, 610, 987
-m4_define([marco_micro_version], [1])
+m4_define([marco_micro_version], [0])
m4_define([marco_version],
[marco_major_version.marco_minor_version.marco_micro_version])
@@ -127,19 +127,12 @@ case "$with_gtk" in
CANBERRA_GTK=libcanberra-gtk3
;;
esac
+GIO_MIN_VERSION=2.25.10
-MARCO_PC_MODULES="gtk+-$GTK_API_VERSION >= $GTK_MIN_VERSION pango >= 1.2.0 $CANBERRA_GTK"
+MARCO_PC_MODULES="gtk+-$GTK_API_VERSION >= $GTK_MIN_VERSION gio-2.0 >= $GIO_MIN_VERSION pango >= 1.2.0 $CANBERRA_GTK"
AC_SUBST(GTK_API_VERSION)
-AC_ARG_ENABLE(mateconf,
- AC_HELP_STRING([--disable-mateconf],
- [disable mateconf usage, for embedded/size-sensitive non-MATE builds]),,
- enable_mateconf=yes)
-
-if test x$enable_mateconf = xyes; then
- AC_DEFINE(HAVE_MATECONF,1,[Build with mateconf support])
- MARCO_PC_MODULES="$MARCO_PC_MODULES mateconf-2.0 >= 1.1.0"
-fi
+GLIB_GSETTINGS
AC_ARG_ENABLE(verbose-mode,
AC_HELP_STRING([--disable-verbose-mode],
@@ -495,18 +488,6 @@ fi
AC_SUBST(GDK_PIXBUF_CSOURCE)
-if test x$enable_mateconf = xyes; then
- AC_PATH_PROG(MATECONFTOOL, mateconftool-2, no)
- if test x"$MATECONFTOOL" = xno; then
- AC_MSG_ERROR([mateconftool-2 executable not found in your path - should be installed with MateConf])
- fi
-
- AM_MATECONF_SOURCE_2
-else
- MATECONF_SCHEMAS_INSTALL_TRUE='#'
- MATECONF_SCHEMAS_INSTALL_FALSE=
-fi
-
AC_PATH_PROG(MATEDIALOG, matedialog, no)
if test x"$MATEDIALOG" = xno; then
AC_MSG_ERROR([matedialog not found in your path - needed for dialogs])
@@ -545,13 +526,6 @@ po/Makefile.in
AC_OUTPUT
-if test x$enable_mateconf = xno; then
- echo "*** WARNING WARNING WARNING WARNING WARNING"
- echo "*** Building without MateConf. This means there's no"
- echo "*** way to change prefs except hacking source code."
- echo "*** This is intended for embedded systems etc., not for normal use."
-fi
-
if test x$enable_verbose_mode = xno; then
echo "*** WARNING WARNING WARNING WARNING WARNING"
echo "*** Building without verbose mode"
@@ -568,7 +542,6 @@ marco-$VERSION (using gtk+-${GTK_API_VERSION}):
source code location: ${srcdir}
compiler: ${CC}
- MateConf: ${enable_mateconf}
XFree86 Xinerama: ${use_xfree_xinerama}
Solaris Xinerama: ${use_solaris_xinerama}
Startup notification: ${have_startup_notification}