summaryrefslogtreecommitdiff
path: root/src/themes/eOS/meson.build
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-07-13 18:54:29 +0800
committerlukefromdc <[email protected]>2019-07-13 22:26:39 +0000
commit1960241cc70814439bfc9432dd94bd6057a60652 (patch)
tree9890aaa5d3471569577f9781465dbf3498784587 /src/themes/eOS/meson.build
parentd86c29b0e518f765e7570573c76bc033fbd17f6d (diff)
downloadmarco-1960241cc70814439bfc9432dd94bd6057a60652.tar.bz2
marco-1960241cc70814439bfc9432dd94bd6057a60652.tar.xz
meson: use install_data to replace install_dir
Diffstat (limited to 'src/themes/eOS/meson.build')
-rw-r--r--src/themes/eOS/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/themes/eOS/meson.build b/src/themes/eOS/meson.build
new file mode 100644
index 00000000..309cae15
--- /dev/null
+++ b/src/themes/eOS/meson.build
@@ -0,0 +1,24 @@
+install_data(
+ 'close.png',
+ 'close_unfocused_over.png',
+ 'close_unfocused.png',
+ 'maximize.png',
+ 'maximize_unfocused_over.png',
+ 'maximize_unfocused.png',
+ 'menu.png',
+ 'menu_prelight.png',
+ 'metacity-theme-1.xml',
+ 'minimize.png',
+ 'minimize_unfocused_over.png',
+ 'minimize_unfocused.png',
+ 'trough_left.png',
+ 'trough_left_unfocused.png',
+ 'trough_middle.png',
+ 'trough_middle_unfocused.png',
+ 'trough_right.png',
+ 'trough_right_unfocused.png',
+ 'unmaximize.png',
+ 'unmaximize_unfocused_over.png',
+ 'unmaximize_unfocused.png',
+ install_dir : join_paths(datadir, 'themes', 'eOS', 'metacity-1')
+)