summaryrefslogtreecommitdiff
path: root/battstat/Makefile.am
diff options
context:
space:
mode:
authorColomban Wendling <[email protected]>2023-06-21 10:11:56 +0200
committerraveit65 <[email protected]>2023-06-21 14:21:19 +0200
commitffe372f717b19cf8d97cb187d63a68da1989e064 (patch)
tree9675272f87c2c49ad45d177f3decf77238aefd9a /battstat/Makefile.am
parent954d2258337cda058a5730cd981e878208818b09 (diff)
downloadmate-applets-ffe372f717b19cf8d97cb187d63a68da1989e064.tar.bz2
mate-applets-ffe372f717b19cf8d97cb187d63a68da1989e064.tar.xz
battstat: Use libtool to build libapm
Apparently there is a build failure on some hosts because the build library didn't have the proper PIC settings, see #651. Using libtool fixes it as it is able to build true shared objects.
Diffstat (limited to 'battstat/Makefile.am')
-rw-r--r--battstat/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/battstat/Makefile.am b/battstat/Makefile.am
index 7606ab4d..ed8d852c 100644
--- a/battstat/Makefile.am
+++ b/battstat/Makefile.am
@@ -8,7 +8,7 @@ APMLIB = -lapm
APMDIR =
APMINC =
else
-APMLIB = apmlib/libapm.a
+APMLIB = apmlib/libapm.la
APMDIR = apmlib
APMINC = -I$(srcdir)/apmlib/
endif