summaryrefslogtreecommitdiff
path: root/command/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-12-25 17:58:28 +0800
committerraveit65 <[email protected]>2020-01-09 11:40:14 +0100
commitb91dbe12e8f334e7fbaf9a36814d36d63c94dfd4 (patch)
tree699e3fa9a88533a37cc364c28b8afbfc0f360973 /command/Makefile.am
parent42022afd3340fc97b8c0c8866f2cd6b1355dee34 (diff)
downloadmate-applets-b91dbe12e8f334e7fbaf9a36814d36d63c94dfd4.tar.bz2
mate-applets-b91dbe12e8f334e7fbaf9a36814d36d63c94dfd4.tar.xz
migrate from intltools to gettext
Diffstat (limited to 'command/Makefile.am')
-rw-r--r--command/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/command/Makefile.am b/command/Makefile.am
index 2a9115d9..4bc5b4e3 100644
--- a/command/Makefile.am
+++ b/command/Makefile.am
@@ -2,7 +2,6 @@ AM_CPPFLAGS = \
$(MATE_APPLETS4_CFLAGS) \
$(MATEDESKTOP_CFLAGS) \
-I$(srcdir) \
- -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
$(DISABLE_DEPRECATED_CFLAGS)
APPLET_LOCATION = $(libexecdir)/command-applet
@@ -13,14 +12,16 @@ command_applet_LDADD = $(MATE_APPLETS4_LIBS) $(MATEDESKTOP_LIBS)
command_applet_CFLAGS = $(WARN_CFLAGS)
appletsdir = $(datadir)/mate-panel/applets
-applets_in_files = org.mate.applets.CommandApplet.mate-panel-applet.in
-applets_DATA = $(applets_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applets_in_files = org.mate.applets.CommandApplet.mate-panel-applet.desktop.in
+applets_DATA = $(applets_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applets_in_files): $(applets_in_files).in Makefile
$(AM_V_GEN)sed \
-e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
$< > $@
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+$(applets_DATA): $(applets_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
servicedir = $(datadir)/dbus-1/services
service_in_files = org.mate.panel.applet.CommandAppletFactory.service.in
@@ -31,7 +32,6 @@ org.mate.panel.applet.CommandAppletFactory.service: $(service_in_files)
-e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
$< > $@
-@INTLTOOL_XML_NOMERGE_RULE@
command_gschema_in_files = org.mate.panel.applet.command.gschema.xml.in
gsettings_SCHEMAS = $(command_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
@@ -41,6 +41,6 @@ EXTRA_DIST = \
$(service_in_files) \
$(command_gschema_in_files)
-CLEANFILES = $(applets_DATA) $(applets_DATA).in $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid
+CLEANFILES = $(applets_DATA) $(applets_in_files) $(service_DATA) $(gsettings_SCHEMAS) *.gschema.valid
-include $(top_srcdir)/git.mk