summaryrefslogtreecommitdiff
path: root/command/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2014-01-26 21:18:17 +0100
committerStefano Karapetsas <[email protected]>2014-01-26 21:18:17 +0100
commitbd4b7678e0dbdc9e72c6edf59456cdf5192313b5 (patch)
tree16f7d4721cf858772e2889e639f036de8b12c672 /command/Makefile.am
parentf39ac1d2cfe5ec92782cad61de1df31e0062d06c (diff)
downloadmate-applets-bd4b7678e0dbdc9e72c6edf59456cdf5192313b5.tar.bz2
mate-applets-bd4b7678e0dbdc9e72c6edf59456cdf5192313b5.tar.xz
Add new command applet
Diffstat (limited to 'command/Makefile.am')
-rw-r--r--command/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/command/Makefile.am b/command/Makefile.am
new file mode 100644
index 00000000..b8bb5029
--- /dev/null
+++ b/command/Makefile.am
@@ -0,0 +1,44 @@
+AM_CPPFLAGS = \
+ $(MATE_APPLETS4_CFLAGS) \
+ -I$(srcdir) \
+ -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+APPLET_LOCATION = $(libexecdir)/command-applet
+
+libexec_PROGRAMS = command-applet
+command_applet_SOURCES = command.c
+command_applet_LDADD = $(MATE_APPLETS4_LIBS)
+command_applet_CFLAGS = $(WARN_CFLAGS)
+
+appletsdir = $(datadir)/mate-panel/applets
+applets_in_files = org.mate.applets.CommandApplet.mate-panel-applet.in
+applets_DATA = $(applets_in_files:.mate-panel-applet.in=.mate-panel-applet)
+
+$(applets_in_files): $(applets_in_files).in Makefile
+ $(AM_V_GEN)sed \
+ -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
+ $< > $@
+%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.mate.panel.applet.CommandAppletFactory.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+org.mate.panel.applet.CommandAppletFactory.service: $(service_in_files)
+ $(AM_V_GEN)sed \
+ -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
+ $< > $@
+
+@INTLTOOL_XML_NOMERGE_RULE@
+gsettings_SCHEMAS = org.mate.panel.applet.command.gschema.xml
+@GSETTINGS_RULES@
+
+%.gschema.xml.in: %.gschema.xml.in.in Makefile
+ $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
+
+EXTRA_DIST = \
+ $(applets_in_files) \
+ $(service_in_files) \
+ $(gsettings_SCHEMAS).in.in
+