summaryrefslogtreecommitdiff
path: root/command/src/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2023-06-19 01:46:33 -0400
committerraveit65 <[email protected]>2023-07-17 02:47:28 +0200
commit168de875415d503d2fc66d28f5e6f87b6871f693 (patch)
tree344cc3ed4f29a6726a2c882fd7aab0ca67f47e02 /command/src/Makefile.am
parent6363c16faf18cc5780bdcb9d53420a583a6482e7 (diff)
downloadmate-applets-168de875415d503d2fc66d28f5e6f87b6871f693.tar.bz2
mate-applets-168de875415d503d2fc66d28f5e6f87b6871f693.tar.xz
command: Port to in-process for wayland compatability
- fix runtime warnings on applet removal - disconnect signal on shutdown that otherwise throws warnings - Required moving a function so it would be defined in time
Diffstat (limited to 'command/src/Makefile.am')
-rw-r--r--command/src/Makefile.am24
1 files changed, 7 insertions, 17 deletions
diff --git a/command/src/Makefile.am b/command/src/Makefile.am
index d0d2065a..3497672d 100644
--- a/command/src/Makefile.am
+++ b/command/src/Makefile.am
@@ -1,36 +1,27 @@
NULL =
+command_applet_libdir= $(pkglibdir)
+command_applet_lib_LTLIBRARIES=libcommand-applet.la
+
AM_CPPFLAGS = \
$(MATE_APPLETS4_CFLAGS) \
-I$(srcdir) \
$(DISABLE_DEPRECATED_CFLAGS) \
$(NULL)
-libexec_PROGRAMS = command-applet
-
-BUILT_SOURCES = \
- command-resources.c \
- command-resources.h \
- $(NULL)
-nodist_command_applet_SOURCES = \
- $(BUILT_SOURCES) \
- $(NULL)
-
-command_applet_SOURCES = \
+libcommand_applet_la_SOURCES = \
command.c \
ma-command.c \
ma-command.h \
+ command-resources.c \
+ command-resources.h \
$(NULL)
-command_applet_LDADD = \
+libcommand_applet_la_LIBADD = \
$(MATE_APPLETS4_LIBS) \
$(NULL)
-command_applet_CFLAGS = \
- $(WARN_CFLAGS) \
- $(NULL)
-
command-resources.c: $(srcdir)/../data/command-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/../data --generate-dependencies $(srcdir)/../data/command-resources.gresource.xml)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data --generate --c-name command $<
@@ -38,7 +29,6 @@ command-resources.h: $(srcdir)/../data/command-resources.gresource.xml $(shell $
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data --generate --c-name command $<
CLEANFILES = \
- $(BUILT_SOURCES) \
$(NULL)
-include $(top_srcdir)/git.mk