summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-10-16 11:44:09 +0200
committerinfirit <[email protected]>2014-10-16 11:44:09 +0200
commit0cfae7c76601fd4f863c150b50c6cfd41b9ad7f2 (patch)
treebad4c67b1fce45cff14ea935530ecd44194369d6 /configure.ac
parent6ae66da5cfa159067868269c8b601eb6902c3613 (diff)
downloadmate-applets-0cfae7c76601fd4f863c150b50c6cfd41b9ad7f2.tar.bz2
mate-applets-0cfae7c76601fd4f863c150b50c6cfd41b9ad7f2.tar.xz
Stickynotes: When explicitely enabled error when gtksourceview is not found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d0880f24..2fbc1e55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,9 +436,13 @@ AC_ARG_ENABLE([stickynotes],
enable_stickynotes=yes)
if test "x$enable_stickynotes" = "xyes"; then
PKG_CHECK_MODULES(STICKYNOTES, gtksourceview-$GTK_API_VERSION,
- enable_stickynotes=yes, enable_stickynotes=no)
+ have_gtksourceview=yes, have_gtksourceview=no)
+
+ if test "x$enable_stickynotes" = "xyes" -a "x$have_gtksourceview" = "xno"; then
+ AC_MSG_ERROR([Stickynotes explicitely requested but dependency not found])
+ fi
fi
-AM_CONDITIONAL(BUILD_STICKYNOTES_APPLET, test "x$enable_stickynotes" = "xyes")
+AM_CONDITIONAL(BUILD_STICKYNOTES_APPLET, test "x$have_gtksourceview" = "xyes")
dnl ***************************************************************************
dnl *** keyboard accessibility status applet check ***