summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-10-19 00:26:42 +0200
committerinfirit <[email protected]>2013-10-19 10:38:02 +0200
commitc759fadd251e4a5b95e0a4b483889f654ac89d62 (patch)
tree55d2c0865ac2ceca8a494a28e87cb1a87944ab6c /configure.ac
parent3a822cb94c27a06bb72921edc1875689818ff0de (diff)
downloadmate-applets-c759fadd251e4a5b95e0a4b483889f654ac89d62.tar.bz2
mate-applets-c759fadd251e4a5b95e0a4b483889f654ac89d62.tar.xz
Move to gucharmap
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 18 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 8e8788bb..92514dac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,8 +28,8 @@ PYGTK_REQUIRED=2.6
PYGOBJECT_REQUIRED=2.6
MATE_ICON_THEME_REQUIRED=1.1.0
LIBXML_REQUIRED=2.5.0
-MUCHARMAP2_REQUIRED=1.5.0
-MUCHARMAP_REQUIRED=1.4.0
+GUCHARMAP2_REQUIRED=2.33.0
+GUCHARMAP_REQUIRED=1.4.0
POLKIT_REQUIRED=0.92
NETWORKMANAGER_REQUIRED=0.7
dnl ***************************************************************************
@@ -238,27 +238,27 @@ fi
AC_SUBST(UPOWER_CFLAGS)
AC_SUBST(UPOWER_LIBS)
-dnl -- check for mucharmap (optional) -----------------------------------------
+dnl -- check for gucharmap (optional) -----------------------------------------
-PKG_CHECK_EXISTS([mucharmap-2 >= $MUCHARMAP2_REQUIRED],
- [have_mucharmap=yes have_mucharmap_2=yes],[have_mucharmap_2=no])
-if test "$have_mucharmap_2" = "yes"; then
- PKG_CHECK_MODULES([MUCHARMAP],[mucharmap-2 >= $MUCHARMAP2_REQUIRED])
+PKG_CHECK_EXISTS([gucharmap-2 >= $GUCHARMAP2_REQUIRED],
+ [have_gucharmap=yes have_gucharmap_2=yes],[have_gucharmap_2=no])
+if test "$have_gucharmap_2" = "yes"; then
+ PKG_CHECK_MODULES([GUCHARMAP],[gucharmap-2 >= $GUCHARMAP2_REQUIRED])
else
- PKG_CHECK_MODULES([MUCHARMAP], [mucharmap >= $MUCHARMAP_REQUIRED],
- [have_mucharmap=yes],[have_mucharmap=no])
+ PKG_CHECK_MODULES([GUCHARMAP], [gucharmap >= $GUCHARMAP_REQUIRED],
+ [have_gucharmap=yes],[have_gucharmap=no])
fi
-if test "$have_mucharmap_2" = "yes"; then
- AC_DEFINE([HAVE_MUCHARMAP_2],[1],[Define if mucharmap API is version 2])
+if test "$have_gucharmap_2" = "yes"; then
+ AC_DEFINE([HAVE_GUCHARMAP_2],[1],[Define if gucharmap API is version 2])
fi
-if test "$have_mucharmap" = "yes"; then
- AC_DEFINE([HAVE_MUCHARMAP],[1],[Mucharmap Available])
+if test "$have_gucharmap" = "yes"; then
+ AC_DEFINE([HAVE_GUCHARMAP],[1],[Gucharmap Available])
else
- AC_MSG_WARN([*** 'charpick' applet will not be built with mucharmap support ***])
+ AC_MSG_WARN([*** 'charpick' applet will not be built with gucharmap support ***])
fi
-AC_SUBST(MUCHARMAP_CFLAGS)
-AC_SUBST(MUCHARMAP_LIBS)
+AC_SUBST(GUCHARMAP_CFLAGS)
+AC_SUBST(GUCHARMAP_LIBS)
dnl -- check for Python modules (optional) ------------------------------
PYGTK_CFLAGS=
@@ -713,8 +713,8 @@ mate-applets-$VERSION configure summary:
- accessx-status $HAVE_XKB
- battstat $build_battstat_applet
- charpick always
- - mucharmap support $have_mucharmap
- - mucharmap-2 support $have_mucharmap_2
+ - gucharmap support $have_gucharmap
+ - gucharmap-2 support $have_gucharmap_2
- cpufreq $build_cpufreq_applet
- building selector $enable_selector
- using PolicyKit $HAVE_POLKIT