summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2014-01-30 15:58:17 +0100
committerStefano Karapetsas <[email protected]>2014-01-30 15:58:17 +0100
commitc8a85a6aa040c1d2505b957af4cfb4bd39466504 (patch)
tree1d60e06e4504a25bf00918a3ee81e847af72bce1 /configure.ac
parentd15349379583695063e692010bdb44e9974c3f18 (diff)
downloadmate-applets-c8a85a6aa040c1d2505b957af4cfb4bd39466504.tar.bz2
mate-applets-c8a85a6aa040c1d2505b957af4cfb4bd39466504.tar.xz
stickynotes: Add undo/redo feature
Using GtkSourceView instead of GtkTextView This adds new dependency to package to build this applet Closes #17 https://github.com/mate-desktop/mate-applets/issues/17
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1e5e882c..02318101 100644
--- a/configure.ac
+++ b/configure.ac
@@ -432,9 +432,14 @@ AM_CONDITIONAL(BUILD_BATTSTAT_APPLET, test x$build_battstat_applet = xyes)
dnl ***************************************************************************
dnl *** Stickynotes specific checks ***
dnl ***************************************************************************
-# AC_ARG_ENABLE(stickynotes, [ --enable-stickynotes build stickynotes
-# [@<:@default: no, transparent upgrade to Tomboy@:>@]], enable_stickynotes="yes", enable_stickynotes="no")
-enable_stickynotes="yes"
+AC_ARG_ENABLE([stickynotes],
+ AC_HELP_STRING([--enable-stickynotes], [Enable stickynotes applet.]),
+ enable_stickynotes=$enableval,
+ enable_stickynotes=yes)
+if test "x$enable_stickynotes" = "xyes"; then
+ PKG_CHECK_MODULES(STICKYNOTES, gtksourceview-$GTK_API_VERSION,
+ enable_stickynotes=yes, enable_stickynotes=no)
+fi
AM_CONDITIONAL(BUILD_STICKYNOTES_APPLET, test "x$enable_stickynotes" = "xyes")
dnl ***************************************************************************