summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-06-12 17:49:56 +0200
committerStefano Karapetsas <[email protected]>2012-06-12 17:49:56 +0200
commit4bbd16182dab69da9ca7ad13309962af40529469 (patch)
treec77202017ea3739f137a86f817bdb2ecef381f80 /configure.in
parentc9b9454068f090a7132c6bea6ac07c91843ffb6e (diff)
downloadmate-applets-4bbd16182dab69da9ca7ad13309962af40529469.tar.bz2
mate-applets-4bbd16182dab69da9ca7ad13309962af40529469.tar.xz
add timer-applet
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 32e4be9c..8ac89658 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl ***************************************************************************
dnl *** configure.in for MATE-APPLETS ***
dnl ***************************************************************************
-AC_INIT(mate-applets, 1.2.3)
+AC_INIT(mate-applets, 1.3.0)
AC_PREREQ(2.59)
AM_CONFIG_HEADER(config.h)
@@ -478,6 +478,15 @@ enable_stickynotes="yes"
AM_CONDITIONAL(BUILD_STICKYNOTES_APPLET, test "x$enable_stickynotes" = "xyes")
dnl ***************************************************************************
+dnl *** Timer applet specific checks ***
+dnl ***************************************************************************
+AC_ARG_ENABLE([timer-applet],
+ AC_HELP_STRING([--enable-timer-applet], [Enable the timer applet.]),
+ enable_timerapplet=$enableval,
+ enable_timerapplet=no)
+AM_CONDITIONAL(BUILD_TIMER_APPLET, test "x$enable_timerapplet" = "xyes")
+
+dnl ***************************************************************************
dnl *** keyboard accessibility status applet check ***
dnl ***************************************************************************
@@ -740,6 +749,14 @@ cpufreq/src/Makefile
cpufreq/src/cpufreq-selector/Makefile
cpufreq/pixmaps/Makefile
cpufreq/help/Makefile
+timer-applet/Makefile
+timer-applet/data/Makefile
+timer-applet/images/Makefile
+timer-applet/src/Makefile
+timer-applet/src/timerapplet/Makefile
+timer-applet/src/timerapplet/controllers/Makefile
+timer-applet/src/timerapplet/core/Makefile
+timer-applet/src/timerapplet/ui/Makefile
null_applet/Makefile
])
@@ -773,6 +790,7 @@ mate-applets-$VERSION configure summary:
- multiload $build_gtop_applets
- stickynotes $enable_stickynotes
- trashapplet always
+ - timer-applet $enable_timerapplet
Using DBUS: $HAVE_DBUS
Using NetworkManager: $HAVE_NETWORKMANAGER