summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSteve Zesch <[email protected]>2012-04-24 15:28:36 -0400
committerSteve Zesch <[email protected]>2012-04-24 15:28:36 -0400
commitb958403a2e06dfc271b121eb325783bc923b089a (patch)
treeb5bbfd82f0f33781610b610ef6c325cae75f122e /configure.in
parent8939ec49c5218f4aaf2d49c7dd80954817f1bbb9 (diff)
downloadmate-applets-b958403a2e06dfc271b121eb325783bc923b089a.tar.bz2
mate-applets-b958403a2e06dfc271b121eb325783bc923b089a.tar.xz
upower support added to battstat. Preparing for 1.2.2 release.mate-applets-1.2.2
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1e9b2aa8..f5d52c72 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl ***************************************************************************
dnl *** configure.in for MATE-APPLETS ***
dnl ***************************************************************************
-AC_INIT(mate-applets, 1.2.1)
+AC_INIT(mate-applets, 1.2.2)
AC_PREREQ(2.59)
AM_CONFIG_HEADER(config.h)
@@ -24,6 +24,7 @@ LIBWNCK_REQUIRED=2.9.3
LIBMATE_DESKTOP_REQUIRED=1.1.0
LIBMATENOTIFY_REQUIRED=1.1.0
HAL_REQUIRED=0.5.3
+UPOWER_REQUIRED=0.9.4
DBUS_REQUIRED=1.1.2
DBUS_GLIB_REQUIRED=0.74
PYGTK_REQUIRED=2.6
@@ -227,6 +228,26 @@ fi
AC_SUBST(HAL_CFLAGS)
AC_SUBST(HAL_LIBS)
+dnl -- checkf or libupower-glib (optional) ------------------------------------
+UPOWER_CFLAGS=
+UPOWER_LIBS=
+AC_ARG_WITH(upower, [ --without-upower build without upower support])
+
+if test "x$with_upower" != xno; then
+ PKG_CHECK_MODULES(UPOWER, upower-glib >= $UPOWER_REQUIRED,
+ HAVE_UPOWER="yes",
+ HAVE_UPOWER="no")
+
+ if test "x$HAVE_UPOWER" = "xyes"; then
+ AC_DEFINE(HAVE_UPOWER, 1, [UPOWER available])
+ fi
+else
+ AC_MSG_WARN(["upower support disabled"])
+fi
+
+AC_SUBST(UPOWER_CFLAGS)
+AC_SUBST(UPOWER_LIBS)
+
dnl -- check for gucharmap (optional) -----------------------------------------
PKG_CHECK_EXISTS([gucharmap-2 >= $GUCHARMAP2_REQUIRED],
@@ -752,5 +773,6 @@ mate-applets-$VERSION configure summary:
Using DBUS: $HAVE_DBUS
Using NetworkManager: $HAVE_NETWORKMANAGER
Using HAL: $HAVE_HAL
+ Using UPOWER: $HAVE_UPOWER
Enabling IPv6: $have_ipv6
" >&2