summaryrefslogtreecommitdiff
path: root/cpufreq/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-06 21:55:35 +0200
committerinfirit <[email protected]>2015-09-06 21:55:35 +0200
commitdf7a7488950139e3884972e2363294051e33d45d (patch)
treec442d94aba98b29a69a743701bf9a7d7a1086950 /cpufreq/Makefile.am
parent6bfc67fc80ba929a740d20edd9ba34927dfefafe (diff)
downloadmate-applets-df7a7488950139e3884972e2363294051e33d45d.tar.bz2
mate-applets-df7a7488950139e3884972e2363294051e33d45d.tar.xz
Rework gsettings schema building
* Bump intltool required version for gsettings support * Extract strings with intltool directly * Let autoconf generate the xml files
Diffstat (limited to 'cpufreq/Makefile.am')
-rw-r--r--cpufreq/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/cpufreq/Makefile.am b/cpufreq/Makefile.am
index ea9ea2aa..af18f188 100644
--- a/cpufreq/Makefile.am
+++ b/cpufreq/Makefile.am
@@ -1,12 +1,10 @@
SUBDIRS = help pixmaps src
@INTLTOOL_XML_NOMERGE_RULE@
-gsettings_SCHEMAS = org.mate.panel.applet.cpufreq.gschema.xml
+cpufreq_gschema_in_files = org.mate.panel.applet.cpufreq.gschema.xml.in
+gsettings_SCHEMAS = $(cpufreq_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
-
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.CPUFreqApplet.mate-panel-applet.in
applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
@@ -37,7 +35,6 @@ CLEANFILES = \
$(applet_DATA) \
$(applet_DATA).in \
$(service_DATA) \
- $(gsettings_SCHEMAS_in) \
$(gsettings_SCHEMAS) \
*.gschema.valid \
*.bak \
@@ -46,7 +43,7 @@ CLEANFILES = \
EXTRA_DIST = \
org.mate.applets.CPUFreqApplet.mate-panel-applet.in.in \
$(service_in_files) \
- $(gsettings_SCHEMAS).in.in \
+ $(cpufreq_gschema_in_files) \
$(builder_DATA) \
$(ui_DATA)