summaryrefslogtreecommitdiff
path: root/cpufreq/src/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-07-18 23:59:25 +0200
committerraveit65 <[email protected]>2020-07-30 18:26:25 +0200
commitfd1a917a0ca74063ed52f9798c9491556b08c8f4 (patch)
treec59a951d7d9e4c362b130e1f075c0601dc173476 /cpufreq/src/Makefile.am
parentc7077cfd71cc74222db699a910f8507c5c68b98c (diff)
downloadmate-applets-fd1a917a0ca74063ed52f9798c9491556b08c8f4.tar.bz2
mate-applets-fd1a917a0ca74063ed52f9798c9491556b08c8f4.tar.xz
cpufreq: Load menu and ui file from resources
Diffstat (limited to 'cpufreq/src/Makefile.am')
-rw-r--r--cpufreq/src/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/cpufreq/src/Makefile.am b/cpufreq/src/Makefile.am
index 83ed7faa..cd64db9e 100644
--- a/cpufreq/src/Makefile.am
+++ b/cpufreq/src/Makefile.am
@@ -5,7 +5,7 @@ endif
SUBDIRS = $(selector_SUBDIR)
AM_CPPFLAGS = \
- -DCPUFREQ_MENU_UI_DIR=\""$(datadir)/mate/ui"\" \
+ -DCPUFREQ_RESOURCE_PATH=\""/org/mate/mate-applets/cpufreq/"\" \
$(MATE_APPLETS4_CFLAGS)
libexec_PROGRAMS = mate-cpufreq-applet
@@ -14,7 +14,13 @@ if HAVE_LIBCPUFREQ
cpufreq_files=cpufreq-monitor-libcpufreq.c cpufreq-monitor-libcpufreq.h
endif
-mate_cpufreq_applet_SOURCES = \
+BUILT_SOURCES = \
+ cpufreq-resources.c cpufreq-resources.h
+
+nodist_mate_cpufreq_applet_SOURCES = \
+ $(BUILT_SOURCES)
+
+mate_cpufreq_applet_SOURCES = \
cpufreq-applet.c cpufreq-applet.h \
cpufreq-utils.c cpufreq-utils.h \
cpufreq-prefs.c cpufreq-prefs.h \
@@ -34,4 +40,13 @@ mate_cpufreq_applet_LDADD = \
$(MATE_APPLETS4_LIBS) \
$(LIBCPUFREQ_LIBS)
+cpufreq-resources.c: $(top_srcdir)/cpufreq/cpufreq-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(top_srcdir)/cpufreq --generate-dependencies $(top_srcdir)/cpufreq/cpufreq-resources.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(top_srcdir)/cpufreq --generate --c-name cpufreq $<
+
+cpufreq-resources.h: $(top_srcdir)/cpufreq/cpufreq-resources.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(top_srcdir)/cpufreq --generate-dependencies $(top_srcdir)/cpufreq/cpufreq-resources.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(top_srcdir)/cpufreq --generate --c-name cpufreq $<
+
+CLEANFILES = \
+ $(BUILT_SOURCES)
+
-include $(top_srcdir)/git.mk