summaryrefslogtreecommitdiff
path: root/netspeed/icons/48x48/devices/Makefile.am
diff options
context:
space:
mode:
authorVictor Kareh <[email protected]>2018-05-02 15:17:17 -0400
committerraveit65 <[email protected]>2018-05-12 22:22:15 +0200
commit2b9d8bf7c7338ed984a3529b06d8551f5fffec88 (patch)
tree77d946f958377a7fe8ad8e7b3d587fc88cf4e9b3 /netspeed/icons/48x48/devices/Makefile.am
parenta03ead3c85f5597d8394bf87b9bbddd76d775ae9 (diff)
downloadmate-applets-2b9d8bf7c7338ed984a3529b06d8551f5fffec88.tar.bz2
mate-applets-2b9d8bf7c7338ed984a3529b06d8551f5fffec88.tar.xz
netspeed: Use theme icons instead of embedded
This removes old icons included with the applet and instead uses icons from the current theme. Known issues: * Loopback interface does not have an icon, instead we use a "reload" icon to simulate it. * PLIP/SLIP interfaces do not have proper icons, I managed to find an old PLIP icon in the hicolor theme and re-purposed it. * Since not all icons have the same levels of scaling, I'm capping the size at 48px to keep all interfaces consistent. * There are no icons for Wireless Quality, so I retained the existing ones for now.
Diffstat (limited to 'netspeed/icons/48x48/devices/Makefile.am')
-rw-r--r--netspeed/icons/48x48/devices/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/netspeed/icons/48x48/devices/Makefile.am b/netspeed/icons/48x48/devices/Makefile.am
new file mode 100644
index 00000000..d2e476dc
--- /dev/null
+++ b/netspeed/icons/48x48/devices/Makefile.am
@@ -0,0 +1,11 @@
+themedir = $(datadir)/icons/hicolor
+size = 48x48
+context = devices
+
+iconsdir = $(themedir)/$(size)/$(context)
+
+icons_DATA = \
+ mate-netspeed-plip.png
+
+EXTRA_DIST = \
+ $(icons_DATA)