summaryrefslogtreecommitdiff
path: root/trashapplet/data/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2023-06-10 19:00:46 -0400
committerraveit65 <[email protected]>2023-07-16 23:06:44 +0200
commit22d571466674641a3a767e577373a3c5f78ab157 (patch)
treee5540d5b9ccaa23284521c231c25afd054589300 /trashapplet/data/Makefile.am
parentffe372f717b19cf8d97cb187d63a68da1989e064 (diff)
downloadmate-applets-22d571466674641a3a767e577373a3c5f78ab157.tar.bz2
mate-applets-22d571466674641a3a767e577373a3c5f78ab157.tar.xz
trash: port to in-process for wayland support
- ensure applet can be left-clicked in wayland - In wayland we have to open the trash on the button press event - In x11 retain the existing behavior of opening the trash on the button release event - ensure both right and left clicks work in wayland - using code borrowed from cpufreq applet - Cleanup X11 checks
Diffstat (limited to 'trashapplet/data/Makefile.am')
-rw-r--r--trashapplet/data/Makefile.am19
1 files changed, 6 insertions, 13 deletions
diff --git a/trashapplet/data/Makefile.am b/trashapplet/data/Makefile.am
index 8603d6c2..f318e0fb 100644
--- a/trashapplet/data/Makefile.am
+++ b/trashapplet/data/Makefile.am
@@ -1,32 +1,25 @@
+APPLET_LOCATION = $(libdir)/mate-applets/libtrashapplet.so
+
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.TrashApplet.mate-panel-applet.desktop.in
applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
- $< > $@
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
+ $< > $@
$(applet_DATA): $(applet_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.TrashAppletFactory.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-org.mate.panel.applet.TrashAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- $< > $@
EXTRA_DIST = \
$(applet_in_files).in \
- $(service_in_files) \
trashapplet-empty-progress.ui \
trashapplet-menu.xml \
trashapplet-resources.gresource.xml
-CLEANFILES = $(applet_DATA) $(applet_in_files) $(service_DATA)
+CLEANFILES = $(applet_DATA) $(applet_in_files)
-include $(top_srcdir)/git.mk