summaryrefslogtreecommitdiff
path: root/trashapplet/src/Makefile.am
diff options
context:
space:
mode:
authorlukefromdc <[email protected]>2023-06-10 19:00:46 -0400
committerraveit65 <[email protected]>2023-07-16 23:06:44 +0200
commit22d571466674641a3a767e577373a3c5f78ab157 (patch)
treee5540d5b9ccaa23284521c231c25afd054589300 /trashapplet/src/Makefile.am
parentffe372f717b19cf8d97cb187d63a68da1989e064 (diff)
downloadmate-applets-22d571466674641a3a767e577373a3c5f78ab157.tar.bz2
mate-applets-22d571466674641a3a767e577373a3c5f78ab157.tar.xz
trash: port to in-process for wayland support
- ensure applet can be left-clicked in wayland - In wayland we have to open the trash on the button press event - In x11 retain the existing behavior of opening the trash on the button release event - ensure both right and left clicks work in wayland - using code borrowed from cpufreq applet - Cleanup X11 checks
Diffstat (limited to 'trashapplet/src/Makefile.am')
-rw-r--r--trashapplet/src/Makefile.am19
1 files changed, 9 insertions, 10 deletions
diff --git a/trashapplet/src/Makefile.am b/trashapplet/src/Makefile.am
index 2def1827..1cad7acd 100644
--- a/trashapplet/src/Makefile.am
+++ b/trashapplet/src/Makefile.am
@@ -4,21 +4,20 @@ AM_CPPFLAGS = -I$(top_srcdir) \
-DGRESOURCE=\""/org/mate/mate-applets/trash/\"" \
${WARN_CFLAGS}
-libexec_PROGRAMS = trashapplet
+trashapplet_libdir= $(pkglibdir)
+trashapplet_lib_LTLIBRARIES=libtrashapplet.la
-BUILT_SOURCES = \
- trashapplet-resources.c \
- trashapplet-resources.h
-
-nodist_trashapplet_SOURCES = $(BUILT_SOURCES)
-trashapplet_SOURCES = \
+libtrashapplet_la_SOURCES = \
trashapplet.c \
trash-empty.h \
trash-empty.c \
xstuff.c \
- xstuff.h
+ xstuff.h \
+ trashapplet-resources.c \
+ trashapplet-resources.h \
+ $(NULL)
-trashapplet_LDADD = \
+libtrashapplet_la_LIBADD = \
$(MATE_APPLETS4_LIBS) \
$(GIO_LIBS) \
-lX11
@@ -30,6 +29,6 @@ trashapplet-resources.h: ../data/trashapplet-resources.gresource.xml $(shell $(G
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir)/../data/ --generate --c-name trashapplet $<
CLEANFILES = \
- $(BUILT_SOURCES)
+ $(NULL)
-include $(top_srcdir)/git.mk