summaryrefslogtreecommitdiff
path: root/command/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'command/data/Makefile.am')
-rw-r--r--command/data/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/command/data/Makefile.am b/command/data/Makefile.am
new file mode 100644
index 00000000..b94e9523
--- /dev/null
+++ b/command/data/Makefile.am
@@ -0,0 +1,42 @@
+APPLET_LOCATION = $(libexecdir)/command-applet
+
+appletsdir = $(datadir)/mate-panel/applets
+applets_in_files = org.mate.applets.CommandApplet.mate-panel-applet.desktop.in
+applets_DATA = $(applets_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
+
+$(applets_in_files): $(applets_in_files).in Makefile
+ $(AM_V_GEN)sed \
+ -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
+ $< > $@
+
+$(applets_DATA): $(applets_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
+
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.mate.panel.applet.CommandAppletFactory.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+org.mate.panel.applet.CommandAppletFactory.service: $(service_in_files)
+ $(AM_V_GEN)sed \
+ -e "s|\@LOCATION\@|$(APPLET_LOCATION)|" \
+ $< > $@
+
+command_gschema_in_files = org.mate.panel.applet.command.gschema.xml.in
+gsettings_SCHEMAS = $(command_gschema_in_files:.xml.in=.xml)
+@GSETTINGS_RULES@
+
+EXTRA_DIST = \
+ $(applets_in_files).in \
+ $(service_in_files) \
+ $(command_gschema_in_files) \
+ command-preferences.ui \
+ command-resources.gresource.xml
+
+CLEANFILES = \
+ $(applets_DATA) \
+ $(applets_in_files) \
+ $(service_DATA) \
+ $(gsettings_SCHEMAS) \
+ *.gschema.valid
+
+-include $(top_srcdir)/git.mk