summaryrefslogtreecommitdiff
path: root/cpufreq/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpufreq/data/Makefile.am')
-rw-r--r--cpufreq/data/Makefile.am18
1 files changed, 5 insertions, 13 deletions
diff --git a/cpufreq/data/Makefile.am b/cpufreq/data/Makefile.am
index b08d6345..c4423f90 100644
--- a/cpufreq/data/Makefile.am
+++ b/cpufreq/data/Makefile.am
@@ -4,39 +4,31 @@ cpufreq_gschema_in_files = org.mate.panel.applet.cpufreq.gschema.xml.in
gsettings_SCHEMAS = $(cpufreq_gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
+APPLET_LOCATION = $(libdir)/mate-applets/libmatecpufreqapplet.so
+
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.CPUFreqApplet.mate-panel-applet.desktop.in
applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
- $< > $@
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
+ $< > $@
$(applet_DATA): $(applet_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.CPUFreqAppletFactory.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-org.mate.panel.applet.CPUFreqAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- $< > $@
CLEANFILES = \
$(applet_DATA) \
$(applet_in_files) \
- $(service_DATA) \
$(gsettings_SCHEMAS) \
*.gschema.valid \
$(NULL)
EXTRA_DIST = \
$(applet_in_files).in \
- $(service_in_files) \
$(cpufreq_gschema_in_files) \
cpufreq-applet-menu.xml \
cpufreq-preferences.ui \