summaryrefslogtreecommitdiff
path: root/mateweather/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mateweather/data/Makefile.am')
-rw-r--r--mateweather/data/Makefile.am24
1 files changed, 21 insertions, 3 deletions
diff --git a/mateweather/data/Makefile.am b/mateweather/data/Makefile.am
index a6bf5ceb..d200608b 100644
--- a/mateweather/data/Makefile.am
+++ b/mateweather/data/Makefile.am
@@ -1,29 +1,47 @@
-APPLET_LOCATION = $(libdir)/mate-applets/libmateweather-applet.so
+applet_in_files = org.mate.applets.MateWeatherApplet.mate-panel-applet.desktop.in
+service_in_files = org.mate.panel.applet.MateWeatherAppletFactory.service.in
+
+if ENABLE_IN_PROCESS
+APPLET_LOCATION = $(pkglibdir)/libmateweather-applet.so
+else !ENABLE_IN_PROCESS
+APPLET_LOCATION = $(libexecdir)/mateweather-applet
+endif !ENABLE_IN_PROCESS
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.applets.MateWeatherApplet.mate-panel-applet.desktop.in
applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
-e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@APPLET_IN_PROCESS\@|$(APPLET_IN_PROCESS)|" \
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
$(applet_DATA): $(applet_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
+if !ENABLE_IN_PROCESS
+servicedir = $(datadir)/dbus-1/services
+service_DATA = $(service_in_files:.service.in=.service)
+$(service_DATA): $(service_in_files) Makefile
+ $(AM_V_GEN)sed \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ $< > $@
+endif !ENABLE_IN_PROCESS
CLEANFILES = \
$(applet_DATA) \
- $(applet_in_files)
+ $(applet_in_files) \
+ $(service_DATA) \
+ $(NULL)
EXTRA_DIST = \
mateweather-applet-menu.xml \
mateweather-dialog.ui \
mateweather-resources.gresource.xml \
$(applet_in_files:=.in) \
+ $(service_in_files) \
$(ui_DATA)
-include $(top_srcdir)/git.mk