summaryrefslogtreecommitdiff
path: root/netspeed/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'netspeed/data/Makefile.am')
-rw-r--r--netspeed/data/Makefile.am29
1 files changed, 24 insertions, 5 deletions
diff --git a/netspeed/data/Makefile.am b/netspeed/data/Makefile.am
index e8bec0e1..b6cb4875 100644
--- a/netspeed/data/Makefile.am
+++ b/netspeed/data/Makefile.am
@@ -1,26 +1,44 @@
NULL =
-APPLET_LOCATION = $(libdir)/mate-applets/libmate-netspeed-applet.so
+applet_in_files = org.mate.applets.NetspeedApplet.mate-panel-applet.desktop.in
+service_in_files = org.mate.panel.applet.NetspeedAppletFactory.service.in
+gschema_in_files = org.mate.panel.applet.netspeed.gschema.xml.in
+
+if ENABLE_IN_PROCESS
+APPLET_LOCATION = $(pkglibdir)/libmate-netspeed-applet.so
+else !ENABLE_IN_PROCESS
+APPLET_LOCATION = $(libexecdir)/mate-netspeed-applet
+endif !ENABLE_IN_PROCESS
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.applets.NetspeedApplet.mate-panel-applet.desktop.in
applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
-e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@APPLET_IN_PROCESS\@|$(APPLET_IN_PROCESS)|" \
$< > $@
$(applet_DATA): $(applet_in_files) Makefile
$(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
-netspeed_gschema_in_files = org.mate.panel.applet.netspeed.gschema.xml.in
-gsettings_SCHEMAS = $(netspeed_gschema_in_files:.xml.in=.xml)
+if !ENABLE_IN_PROCESS
+servicedir = $(datadir)/dbus-1/services
+service_DATA = $(service_in_files:.service.in=.service)
+
+$(service_DATA): $(service_in_files) Makefile
+ $(AM_V_GEN)sed \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ $< > $@
+endif !ENABLE_IN_PROCESS
+
+gsettings_SCHEMAS = $(gschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
EXTRA_DIST = \
$(applet_in_files).in \
- $(netspeed_gschema_in_files) \
+ $(service_in_files) \
+ $(gschema_in_files) \
netspeed-details.ui \
netspeed-menu.xml \
netspeed-preferences.ui \
@@ -29,6 +47,7 @@ EXTRA_DIST = \
CLEANFILES = \
$(gsettings_SCHEMAS) \
+ $(service_DATA) \
$(applet_in_files) \
$(applet_DATA)