summaryrefslogtreecommitdiff
path: root/stickynotes/pixmaps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'stickynotes/pixmaps/Makefile.am')
-rw-r--r--stickynotes/pixmaps/Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/stickynotes/pixmaps/Makefile.am b/stickynotes/pixmaps/Makefile.am
new file mode 100644
index 00000000..95634b58
--- /dev/null
+++ b/stickynotes/pixmaps/Makefile.am
@@ -0,0 +1,65 @@
+## Process this file with automake to produce Makefile.in
+
+stickynotes_applet_pixmapsdir = $(datadir)/pixmaps/stickynotes
+stickynotes_applet_pixmaps_DATA = \
+ locked.png \
+ unlocked.png \
+ close.png \
+ resize_se.png \
+ resize_sw.png
+
+icons = \
+ mate-sticky-notes-applet.16.png \
+ mate-sticky-notes-applet.32.png \
+ mate-sticky-notes-applet.22.png \
+ mate-sticky-notes-applet.24.png \
+ mate-sticky-notes-applet.svg
+
+EXTRA_DIST = \
+ $(stickynotes_applet_pixmaps_DATA) \
+ $(icons)
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+uninstall-local:
+ for icon in $(icons); do \
+ SIZE=`echo $$icon | cut -d. -f2`; \
+ FILE=`echo $$icon | cut -d. -f1,3`; \
+ if [ "$$SIZE" = "svg" ]; then \
+ SIZE="scalable"; \
+ FILE="$$FILE.svg"; \
+ else \
+ SIZE="$${SIZE}x$${SIZE}"; \
+ fi; \
+ rm -f $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
+ done
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+install-data-local:
+ for icon in $(icons); do \
+ SIZE=`echo $$icon | cut -d. -f2`; \
+ FILE=`echo $$icon | cut -d. -f1,3`; \
+ if [ "$$SIZE" = "svg" ]; then \
+ SIZE="scalable"; \
+ FILE="$$FILE.svg"; \
+ else \
+ SIZE="$${SIZE}x$${SIZE}"; \
+ fi; \
+ mkdir -p $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/; \
+ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
+ done
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+-include $(top_srcdir)/git.mk