summaryrefslogtreecommitdiff
path: root/help/meson.build
diff options
context:
space:
mode:
authorzhuyaliang <[email protected]>2021-07-25 11:52:47 +0800
committerraveit65 <[email protected]>2021-07-30 19:02:49 +0200
commit8dca108a6a4bed0b3411e41cb04b143c71036b67 (patch)
tree35632a66e2d50c89a690e5202a2e0ff56e7285b6 /help/meson.build
parenta1216168706c08384154d3cea579d223fdc9e81d (diff)
downloadmate-calc-8dca108a6a4bed0b3411e41cb04b143c71036b67.tar.bz2
mate-calc-8dca108a6a4bed0b3411e41cb04b143c71036b67.tar.xz
Add build support for meson
Diffstat (limited to 'help/meson.build')
-rw-r--r--help/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/help/meson.build b/help/meson.build
new file mode 100644
index 0000000..bbe3028
--- /dev/null
+++ b/help/meson.build
@@ -0,0 +1,33 @@
+mate_calc_help_pages = [
+ 'absolute.page',
+ 'base.page',
+ 'boolean.page',
+ 'complex.page',
+ 'conv-base.page',
+ 'conv-character.page',
+ 'conv-currency.page',
+ 'conv-length.page',
+ 'conv-time.page',
+ 'conv-weight.page',
+ 'equation.page',
+ 'factorial.page',
+ 'factorize.page',
+ 'financial.page',
+ 'functions.page',
+ 'index.page',
+ 'keyboard.page',
+ 'legal.xml',
+ 'logarithm.page',
+ 'modulus.page',
+ 'mouse.page',
+ 'number-display.page',
+ 'percentage.page',
+ 'power.page',
+ 'scientific.page',
+ 'superscript.page',
+ 'trigonometry.page',
+ 'variables.page'
+]
+gnome.yelp(meson.project_name(),
+ sources: mate_calc_help_pages,
+)