summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-10-13 11:28:28 +0200
committerStefano Karapetsas <[email protected]>2012-10-13 11:28:28 +0200
commit49d65611edf1a28df001fef2fa9896919544729d (patch)
treeddde080c5756ef4ef1f15bc48f6d584057a6d337 /Makefile.am
parent2b96b475c36a35871d3a0ac13a7693eb102f5a6d (diff)
downloadmate-control-center-49d65611edf1a28df001fef2fa9896919544729d.tar.bz2
mate-control-center-49d65611edf1a28df001fef2fa9896919544729d.tar.xz
add gsettings schema and remove mateconf one
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 10 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 42039d93..1e337dc4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,15 +13,19 @@ if HAVE_TYPING_BREAK
SUBDIRS += typing-break
endif
-schemasdir = @MATECONF_SCHEMA_FILE_DIR@
-schemas_in_files = mate-control-center.schemas.in
-schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
-@INTLTOOL_SCHEMAS_RULE@
+@INTLTOOL_XML_NOMERGE_RULE@
+gsettings_SCHEMAS = org.mate.control-center.gschema.xml
+@GSETTINGS_RULES@
+
+%.gschema.xml.in: %.gschema.xml.in.in Makefile
+ $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
ACLOCAL_AMFLAGS = -I m4
CLEANFILES = \
- $(schemas_DATA)
+ $(gsettings_SCHEMAS_in) \
+ $(gsettings_SCHEMAS) \
+ *.gschema.valid
DISTCLEANFILES = \
mate-doc-utils.make
@@ -46,7 +50,7 @@ MAINTAINERCLEANFILES = \
`find "$(srcdir)" -type f -name Makefile.in -print`
EXTRA_DIST = \
- $(schemas_in_files) \
+ $(gsettings_schemas_in_in) \
MAINTAINERS \
mate-doc-utils.make
@@ -56,15 +60,6 @@ GITIGNOREFILES=m4
-include $(top_srcdir)/git.mk
-install-data-local:
-if MATECONF_SCHEMAS_INSTALL
- if test -z "$(DESTDIR)" ; then \
- for p in $(schemas_DATA) ; do \
- MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule $(top_builddir)/$$p >&1 > /dev/null; \
- done \
- fi
-endif
-
dist-hook:
@if test -d "$(srcdir)/.git"; \
then \