summaryrefslogtreecommitdiff
path: root/capplets/about-me/Makefile.am
diff options
context:
space:
mode:
authoryetist <[email protected]>2018-07-03 16:47:21 +0800
committerraveit65 <[email protected]>2018-08-30 11:59:55 +0200
commit28c5512f3e32b6f795f80376e2f1832b6f884a79 (patch)
tree8e6a53a7c59f7cb6a133b159860d8d1a9d10244f /capplets/about-me/Makefile.am
parent4de92a5fd5b8a43285e572a981ec9949887c196a (diff)
downloadmate-control-center-28c5512f3e32b6f795f80376e2f1832b6f884a79.tar.bz2
mate-control-center-28c5512f3e32b6f795f80376e2f1832b6f884a79.tar.xz
get/set user face icon use accounts service
- If get icon from AccountsService failed, fallback to use ~/.face file. - If not setup user icon file, use "avatar-default" icon as default image to show. - Check dependencies of accountsservice, default is enable when accountsservice dependency exists. Added by raveit65 <[email protected]>.
Diffstat (limited to 'capplets/about-me/Makefile.am')
-rw-r--r--capplets/about-me/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/capplets/about-me/Makefile.am b/capplets/about-me/Makefile.am
index f510c81f..01b07f95 100644
--- a/capplets/about-me/Makefile.am
+++ b/capplets/about-me/Makefile.am
@@ -28,6 +28,9 @@ marshal.c: fprintd-marshal.list
bin_PROGRAMS = mate-about-me
mate_about_me_LDADD = $(MATECC_CAPPLETS_LIBS)
+if HAVE_ACCOUNTSSERVICE
+mate_about_me_LDADD += $(ACCOUNTSSERVICE_LIBS)
+endif
mate_about_me_LDFLAGS = -export-dynamic
@INTLTOOL_DESKTOP_RULE@
@@ -47,6 +50,11 @@ AM_CPPFLAGS = \
-DMATECC_PIXMAP_DIR="\"$(pkgdatadir)/pixmaps\"" \
-DMATELOCALEDIR="\"$(datadir)/locale\""
+if HAVE_ACCOUNTSSERVICE
+AM_CPPFLAGS += \
+ $(ACCOUNTSSERVICE_CFLAGS)
+endif
+
CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(MARSHALFILES)
EXTRA_DIST = $(ui_files) fprintd-marshal.list