summaryrefslogtreecommitdiff
path: root/capplets/about-me/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-05-07 00:05:26 +0200
committerlukefromdc <[email protected]>2019-05-11 00:59:53 +0000
commiteafb5fddf84324ebf6b0cc90422f10ee314b5b28 (patch)
treeb7569aab227398638c9504056c1892bc8ea605cd /capplets/about-me/Makefile.am
parent962f1b0464dfcac6223b6ae2b8e8228863800ea2 (diff)
downloadmate-control-center-eafb5fddf84324ebf6b0cc90422f10ee314b5b28.tar.bz2
mate-control-center-eafb5fddf84324ebf6b0cc90422f10ee314b5b28.tar.xz
capplets: Use gresources for UI files
Diffstat (limited to 'capplets/about-me/Makefile.am')
-rw-r--r--capplets/about-me/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/capplets/about-me/Makefile.am b/capplets/about-me/Makefile.am
index 453474c0..aee23c53 100644
--- a/capplets/about-me/Makefile.am
+++ b/capplets/about-me/Makefile.am
@@ -4,6 +4,9 @@ cappletname = about-me
ui_files = mate-about-me-dialog.ui mate-about-me-password.ui mate-about-me-fingerprint.ui
Desktop_in_files = mate-about-me.desktop.in
+BUILT_SOURCES = marshal.c marshal.h mate-about-me-resources.h mate-about-me-resources.c
+nodist_mate_about_me_SOURCES = \
+ $(BUILT_SOURCES)
mate_about_me_SOURCES = \
mate-about-me-password.c \
mate-about-me-password.h \
@@ -11,17 +14,15 @@ mate_about_me_SOURCES = \
e-image-chooser.h \
mate-about-me-fingerprint.c \
mate-about-me-fingerprint.h \
- $(MARSHALFILES) \
fingerprint-strings.h \
mate-about-me.c
-MARSHALFILES = marshal.c marshal.h
-BUILT_SOURCES = $(MARSHALFILES)
-
marshal.h: fprintd-marshal.list
@GLIB_GENMARSHAL@ --prefix=fprintd_marshal $< --header > $@
marshal.c: fprintd-marshal.list
@GLIB_GENMARSHAL@ --prefix=fprintd_marshal $< --body --header > $@
+mate-about-me-resources.h mate-about-me-resources.c: org.mate.mcc.am.gresource.xml Makefile $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/org.mate.mcc.am.gresource.xml)
+ $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate --c-name about_me $<
bin_PROGRAMS = mate-about-me
@@ -36,15 +37,11 @@ mate_about_me_LDFLAGS = -export-dynamic
desktopdir = $(datadir)/applications
desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
-uidir = $(pkgdatadir)/ui
-ui_DATA = $(ui_files)
-
AM_CPPFLAGS = \
$(MATECC_CAPPLETS_CFLAGS) \
$(LIBEBOOK_CFLAGS) \
-DDATADIR="\"$(datadir)\"" \
-DMATECC_DATA_DIR="\"$(pkgdatadir)\"" \
- -DMATECC_UI_DIR="\"$(uidir)\"" \
-DMATECC_PIXMAP_DIR="\"$(pkgdatadir)/pixmaps\"" \
-DMATELOCALEDIR="\"$(datadir)/locale\""
@@ -53,7 +50,11 @@ AM_CPPFLAGS += \
$(ACCOUNTSSERVICE_CFLAGS)
endif
-CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(MARSHALFILES)
-EXTRA_DIST = $(ui_files) fprintd-marshal.list $(Desktop_in_files)
+CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(BUILT_SOURCES)
+EXTRA_DIST = \
+ $(ui_files) \
+ fprintd-marshal.list \
+ $(Desktop_in_files) \
+ org.mate.mcc.am.gresource.xml
-include $(top_srcdir)/git.mk