summaryrefslogtreecommitdiff
path: root/capplets/accessibility/at-properties/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 21:51:44 -0300
committerPerberos <[email protected]>2011-12-01 21:51:44 -0300
commit0b0e6bc987da4fd88a7854ebb12bde705e92c428 (patch)
tree47d329edd31c67eaa36b2147780e37e197e901b5 /capplets/accessibility/at-properties/Makefile.am
downloadmate-control-center-0b0e6bc987da4fd88a7854ebb12bde705e92c428.tar.bz2
mate-control-center-0b0e6bc987da4fd88a7854ebb12bde705e92c428.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'capplets/accessibility/at-properties/Makefile.am')
-rw-r--r--capplets/accessibility/at-properties/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/capplets/accessibility/at-properties/Makefile.am b/capplets/accessibility/at-properties/Makefile.am
new file mode 100644
index 00000000..c24d0181
--- /dev/null
+++ b/capplets/accessibility/at-properties/Makefile.am
@@ -0,0 +1,31 @@
+bin_PROGRAMS = mate-at-properties
+
+mate_at_properties_LDADD = $(AT_CAPPLET_LIBS) $(MATECC_CAPPLETS_LIBS) $(top_builddir)/capplets/common/libcommon.la
+mate_at_properties_SOURCES = \
+ main.c
+mate_at_properties_LDFLAGS = -export-dynamic
+
+@INTLTOOL_DESKTOP_RULE@
+
+desktopdir = $(datadir)/applications
+Desktop_in_files = at-properties.desktop.in
+desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
+
+pixmapdir = $(pkgdatadir)/pixmaps
+pixmap_DATA = \
+ at-startup.png \
+ at-support.png
+
+uidir = $(pkgdatadir)/ui
+ui_DATA = at-enable-dialog.ui
+
+INCLUDES = $(AT_CAPPLET_CFLAGS) \
+ $(MATECC_CAPPLETS_CFLAGS) \
+ -DUIDIR=\""$(uidir)"\" \
+ -DPIXMAPDIR=\""$(pixmapdir)"\" \
+ -DMATECC_DATA_DIR="\"$(pkgdatadir)\"" \
+ -DMATELOCALEDIR="\"$(datadir)/locale\""
+CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(Desktop_in_files) $(desktop_DATA)
+EXTRA_DIST = $(ui_DATA) $(pixmap_DATA)
+
+-include $(top_srcdir)/git.mk