summaryrefslogtreecommitdiff
path: root/capplets/display/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-10-16 16:50:40 +0800
committerraveit65 <[email protected]>2019-11-07 13:20:17 +0100
commit235e8ed2e122140a8476ba91b365ec92a5103530 (patch)
treec072b4e510df11c859cbd69953b15cd886e27697 /capplets/display/Makefile.am
parent0470814242979fdf1fe3d78b8e203edf87156bdd (diff)
downloadmate-control-center-235e8ed2e122140a8476ba91b365ec92a5103530.tar.bz2
mate-control-center-235e8ed2e122140a8476ba91b365ec92a5103530.tar.xz
migrate from intltool to gettext
Diffstat (limited to 'capplets/display/Makefile.am')
-rw-r--r--capplets/display/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/capplets/display/Makefile.am b/capplets/display/Makefile.am
index 058e206d..c5e92882 100644
--- a/capplets/display/Makefile.am
+++ b/capplets/display/Makefile.am
@@ -37,16 +37,16 @@ polkit_policydir = $(datadir)/polkit-1/actions
dist_polkit_policy_DATA = \
org.mate.randr.policy
-# You will need a recent intltool or the patch from this bug
-# http://bugzilla.gnome.org/show_bug.cgi?id=462312
-@INTLTOOL_POLICY_RULE@
-
-@INTLTOOL_DESKTOP_RULE@
+%.policy: %.policy.in
+ $(AM_V_GEN) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
desktopdir = $(datadir)/applications
Desktop_in_files = mate-display-properties.desktop.in
desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
+$(desktop_DATA): $(Desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
AM_CPPFLAGS = $(DISPLAY_CAPPLET_CFLAGS) \
$(MATECC_CAPPLETS_CFLAGS) \
-DSBINDIR="\"$(sbindir)\"" \