summaryrefslogtreecommitdiff
path: root/capplets/keyboard/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 21:51:44 -0300
committerPerberos <[email protected]>2011-12-01 21:51:44 -0300
commit0b0e6bc987da4fd88a7854ebb12bde705e92c428 (patch)
tree47d329edd31c67eaa36b2147780e37e197e901b5 /capplets/keyboard/Makefile.am
downloadmate-control-center-0b0e6bc987da4fd88a7854ebb12bde705e92c428.tar.bz2
mate-control-center-0b0e6bc987da4fd88a7854ebb12bde705e92c428.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'capplets/keyboard/Makefile.am')
-rw-r--r--capplets/keyboard/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/capplets/keyboard/Makefile.am b/capplets/keyboard/Makefile.am
new file mode 100644
index 00000000..5705b01f
--- /dev/null
+++ b/capplets/keyboard/Makefile.am
@@ -0,0 +1,42 @@
+# This is used in MATECC_CAPPLETS_CFLAGS
+cappletname = keyboard
+
+bin_PROGRAMS = mate-keyboard-properties
+
+mate_keyboard_properties_SOURCES = \
+ mate-keyboard-properties.c \
+ mate-keyboard-properties-a11y.c \
+ mate-keyboard-properties-a11y.h \
+ mate-keyboard-properties-xkb.c \
+ mate-keyboard-properties-xkbmc.c \
+ mate-keyboard-properties-xkblt.c \
+ mate-keyboard-properties-xkbltadd.c \
+ mate-keyboard-properties-xkbot.c \
+ mate-keyboard-properties-xkbpv.c \
+ mate-keyboard-properties-xkb.h
+
+mate_keyboard_properties_LDADD = $(MATECC_CAPPLETS_LIBS) $(LIBMATEKBDUI_LIBS)
+
+@INTLTOOL_DESKTOP_RULE@
+
+uidir = $(pkgdatadir)/ui
+dist_ui_DATA = mate-keyboard-properties-a11y-notifications.ui \
+ mate-keyboard-properties-dialog.ui \
+ mate-keyboard-properties-layout-chooser.ui \
+ mate-keyboard-properties-model-chooser.ui \
+ mate-keyboard-properties-options-dialog.ui
+
+desktopdir = $(datadir)/applications
+Desktop_in_files = keyboard.desktop.in
+desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
+
+INCLUDES = \
+ $(MATECC_CAPPLETS_CFLAGS) \
+ $(LIBMATEKBDUI_CFLAGS) \
+ -DMATELOCALEDIR="\"$(datadir)/locale\"" \
+ -DMATECC_DATA_DIR="\"$(pkgdatadir)\"" \
+ -DMATECC_UI_DIR="\"$(uidir)\""
+CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(Desktop_in_files) $(desktop_DATA)
+EXTRA_DIST = $(ui_DATA)
+
+-include $(top_srcdir)/git.mk