summaryrefslogtreecommitdiff
path: root/capplets/windows/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-10-16 16:50:40 +0800
committerraveit65 <[email protected]>2019-11-07 13:20:17 +0100
commit235e8ed2e122140a8476ba91b365ec92a5103530 (patch)
treec072b4e510df11c859cbd69953b15cd886e27697 /capplets/windows/Makefile.am
parent0470814242979fdf1fe3d78b8e203edf87156bdd (diff)
downloadmate-control-center-235e8ed2e122140a8476ba91b365ec92a5103530.tar.bz2
mate-control-center-235e8ed2e122140a8476ba91b365ec92a5103530.tar.xz
migrate from intltool to gettext
Diffstat (limited to 'capplets/windows/Makefile.am')
-rw-r--r--capplets/windows/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/capplets/windows/Makefile.am b/capplets/windows/Makefile.am
index 63f75fbb..92175d2c 100644
--- a/capplets/windows/Makefile.am
+++ b/capplets/windows/Makefile.am
@@ -10,12 +10,13 @@ mate_window_properties_SOURCES = \
mate-metacity-support.c \
mate-window-properties.c
-@INTLTOOL_DESKTOP_RULE@
-
desktopdir = $(datadir)/applications
Desktop_in_files = mate-window-properties.desktop.in
desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
+$(desktop_DATA): $(Desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
AM_CPPFLAGS = $(MATECC_CAPPLETS_CFLAGS) \
-DUIDIR=\""$(uidir)"\" \
-DPIXMAPDIR=\""$(pixmapdir)"\"