summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authoryetist <[email protected]>2018-07-03 16:47:21 +0800
committerraveit65 <[email protected]>2018-08-30 11:59:55 +0200
commit28c5512f3e32b6f795f80376e2f1832b6f884a79 (patch)
tree8e6a53a7c59f7cb6a133b159860d8d1a9d10244f /configure.ac
parent4de92a5fd5b8a43285e572a981ec9949887c196a (diff)
downloadmate-control-center-28c5512f3e32b6f795f80376e2f1832b6f884a79.tar.bz2
mate-control-center-28c5512f3e32b6f795f80376e2f1832b6f884a79.tar.xz
get/set user face icon use accounts service
- If get icon from AccountsService failed, fallback to use ~/.face file. - If not setup user icon file, use "avatar-default" icon as default image to show. - Check dependencies of accountsservice, default is enable when accountsservice dependency exists. Added by raveit65 <[email protected]>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5fe3fd6e..a113da09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,24 @@ AC_SUBST(WARN_CFLAGS)
AM_CONDITIONAL(HAVE_LIBMATESLAB, [test $have_libmateslab = yes])
+dnl
+dnl Check dependencies of accountsservice
+dnl
+
+ACCOUNTSSERVICE_REQUIRED=0.6.21
+
+AC_ARG_WITH([accountsservice], AC_HELP_STRING([--without-accountsservice], [disable accountsservice support]))
+have_accountsservice=no
+if test x$with_accountsservice != xno; then
+ PKG_CHECK_MODULES(ACCOUNTSSERVICE, accountsservice >= $ACCOUNTSSERVICE_REQUIRED, have_accountsservice=yes, have_accountsservice=no)
+fi
+if test "x$have_accountsservice" = "xyes"; then
+ AC_DEFINE(HAVE_ACCOUNTSSERVICE, 1, [ACCOUNTSSERVICE Support.])
+fi
+
+AM_CONDITIONAL([HAVE_ACCOUNTSSERVICE], [test "x$have_accountsservice" = xyes])
+
+
PKG_CHECK_MODULES(FONT_CAPPLET, $COMMON_MODULES pango)
PKG_CHECK_MODULES(FONT_VIEWER, $COMMON_MODULES fontconfig freetype2 mate-desktop-2.0)
@@ -311,4 +329,5 @@ echo "
Appindicator: ${enable_appindicator}
Libmate-slab: ${have_libmateslab}
+ Accountsservice: ${have_accountsservice}
"