summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <[email protected]>2014-05-11 11:37:51 +0200
committerStefano Karapetsas <[email protected]>2014-05-11 11:37:51 +0200
commit7cde88457278bf9a14fd0dd6643a8f793e829555 (patch)
tree5df5295e6c1a10d4e68a937a61b9fb4d8f97aa67 /configure.ac
parentf60fb4469756aa9672523c2b63c1e89336c6a789 (diff)
downloadmate-control-center-7cde88457278bf9a14fd0dd6643a8f793e829555.tar.bz2
mate-control-center-7cde88457278bf9a14fd0dd6643a8f793e829555.tar.xz
Rename libslab to libmate-slab
https://github.com/mate-desktop/mate-control-center/issues/100 This is to avoid package name and version conflicts with libslab0 / libslab0a which existed in Debian until squeeze. MATE components (currently only gnome-main-menu) depending on libmate-slab0 have to be patch accordingly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 7113bd2f..db15b374 100644
--- a/configure.ac
+++ b/configure.ac
@@ -182,20 +182,20 @@ AC_SUBST(GTK_ENGINE_DIR)
PKG_CHECK_MODULES(GLIB, glib-2.0 $GMODULE_ADD)
dnl
-dnl Check dependencies of libslab
+dnl Check dependencies of libmate-slab
dnl
PKG_CHECK_MODULES(LIBSLAB, [
gio-2.0 mate-desktop-2.0 librsvg-2.0 libmate-menu pango
],
- have_libslab=yes,
- have_libslab=no)
+ have_libmateslab=yes,
+ have_libmateslab=no)
WARN_CFLAGS="-Wall"
-AC_SUBST(LIBSLAB_CFLAGS)
-AC_SUBST(LIBSLAB_LIBS)
+AC_SUBST(LIBMATESLAB_CFLAGS)
+AC_SUBST(LIBMATESLAB_LIBS)
AC_SUBST(WARN_CFLAGS)
-AM_CONDITIONAL(HAVE_LIBSLAB, [test $have_libslab = yes])
+AM_CONDITIONAL(HAVE_LIBMATESLAB, [test $have_libmateslab = yes])
dnl
dnl Check for Xft version 2; we build in extra functionality to the font capplet
@@ -371,7 +371,7 @@ help/Makefile
libwindow-settings/Makefile
libwindow-settings/mate-window-settings-2.0.pc
po/Makefile.in
-libslab/libslab.pc
+libslab/mate-slab.pc
libslab/Makefile
shell/Makefile
shell/matecc.desktop.in
@@ -390,7 +390,7 @@ echo "
GTK+ API version: ${GTK_API_VERSION}
Appindicator: ${enable_appindicator}
- Libslab: ${have_libslab}
+ Libmate-slab: ${have_libmateslab}
XCursor support: ${have_xcursor}
XInput support: ${have_xinput}
Ubuntu hacks: ${enable_ubuntu}