summaryrefslogtreecommitdiff
path: root/font-viewer/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-10-16 16:50:40 +0800
committerraveit65 <[email protected]>2019-11-07 13:20:17 +0100
commit235e8ed2e122140a8476ba91b365ec92a5103530 (patch)
treec072b4e510df11c859cbd69953b15cd886e27697 /font-viewer/Makefile.am
parent0470814242979fdf1fe3d78b8e203edf87156bdd (diff)
downloadmate-control-center-235e8ed2e122140a8476ba91b365ec92a5103530.tar.bz2
mate-control-center-235e8ed2e122140a8476ba91b365ec92a5103530.tar.xz
migrate from intltool to gettext
Diffstat (limited to 'font-viewer/Makefile.am')
-rw-r--r--font-viewer/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/font-viewer/Makefile.am b/font-viewer/Makefile.am
index b71ed500..dad9d5ac 100644
--- a/font-viewer/Makefile.am
+++ b/font-viewer/Makefile.am
@@ -34,6 +34,8 @@ thumbnailer_DATA = mate-font-viewer.thumbnailer
desktopdir = $(datadir)/applications
desktop_in_files = mate-font-viewer.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+$(desktop_DATA): $(desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
install-data-local: install-desktop-database
@@ -43,10 +45,6 @@ install-desktop-database: install-desktopDATA
uninstall-local:
rm -f $(DESTDIR)$(desktopdir)/mimeinfo.cache
-@INTLTOOL_DESKTOP_RULE@
-@INTLTOOL_DIRECTORY_RULE@
-@INTLTOOL_SCHEMAS_RULE@
-
CLEANFILES = $(desktop_DATA) \
$(schemas_DATA) $(directory_DATA)