summaryrefslogtreecommitdiff
path: root/capplets/appearance/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/appearance/data/Makefile.am')
-rw-r--r--capplets/appearance/data/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/capplets/appearance/data/Makefile.am b/capplets/appearance/data/Makefile.am
index 4941da96..fc78ee53 100644
--- a/capplets/appearance/data/Makefile.am
+++ b/capplets/appearance/data/Makefile.am
@@ -17,15 +17,13 @@ dist_pixmap_DATA = \
mouse-cursor-white.png \
mouse-cursor-white-large.png
-@INTLTOOL_DESKTOP_RULE@
-
desktopdir = $(datadir)/applications
desktop_in_files = \
mate-appearance-properties.desktop.in \
mate-theme-installer.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-
-@INTLTOOL_XML_RULE@
+$(desktop_DATA): $(desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
xml_in_files = \
mate-theme-package.xml.in
@@ -33,6 +31,9 @@ xml_in_files = \
mimedir = $(datadir)/mime/packages
mime_DATA = $(xml_in_files:.xml.in=.xml)
+$(mime_DATA): $(xml_in_files)
+ $(AM_V_GEN) GETTEXTDATADIR=$(top_srcdir) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+
install-data-hook:
if ENABLE_UPDATE_MIMEDB
$(UPDATE_MIME_DATABASE) "$(DESTDIR)$(datadir)/mime"