summaryrefslogtreecommitdiff
path: root/capplets/default-applications/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/default-applications/Makefile.am')
-rw-r--r--capplets/default-applications/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/capplets/default-applications/Makefile.am b/capplets/default-applications/Makefile.am
index a422d765..4adbc4fc 100644
--- a/capplets/default-applications/Makefile.am
+++ b/capplets/default-applications/Makefile.am
@@ -3,6 +3,8 @@ SUBDIRS = icons
# This is used in MATECC_CAPPLETS_CFLAGS
cappletname = mate-default-applications-properties
+ui_files = mate-default-applications-properties.ui
+
bin_PROGRAMS = mate-default-applications-properties
BUILT_SOURCES = \
@@ -17,6 +19,8 @@ mate_default_applications_properties_SOURCES = \
@INTLTOOL_DESKTOP_RULE@
+include $(top_srcdir)/gla11y.mk
+
desktopdir = $(datadir)/applications
Desktop_in_files = mate-default-applications-properties.desktop.in
desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
@@ -33,7 +37,7 @@ AM_CPPFLAGS = \
mate-default-applications-properties-resources.h mate-default-applications-properties-resources.c: org.mate.mcc.da.gresource.xml Makefile $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/org.mate.mcc.da.gresource.xml)
$(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate --c-name default_applications $<
-CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(autostart_DATA) $(BUILT_SOURCES)
+CLEANFILES = $(MATECC_CAPPLETS_CLEANFILES) $(desktop_DATA) $(autostart_DATA) $(BUILT_SOURCES) $(GLA11Y_OUTPUT)
EXTRA_DIST = \
mate-default-applications.pc.in \
mate-default-applications-properties.ui \