summaryrefslogtreecommitdiff
path: root/capplets/network/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/network/Makefile.am')
-rw-r--r--capplets/network/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/capplets/network/Makefile.am b/capplets/network/Makefile.am
index 7ac02281..90abdf1a 100644
--- a/capplets/network/Makefile.am
+++ b/capplets/network/Makefile.am
@@ -11,14 +11,15 @@ nodist_mate_network_properties_SOURCES = \
mate_network_properties_SOURCES = mate-network-properties.c
mate_network_properties_LDADD = $(MATECC_CAPPLETS_LIBS)
-@INTLTOOL_DESKTOP_RULE@
-
include $(top_srcdir)/gla11y.mk
desktopdir = $(datadir)/applications
desktop_in_files = mate-network-properties.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+$(desktop_DATA): $(desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
mate-network-properties-resources.h mate-network-properties-resources.c: org.mate.mcc.network.gresource.xml Makefile $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/org.mate.mcc.network.gresource.xml)
$(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate --c-name network $<