summaryrefslogtreecommitdiff
path: root/capplets/windows/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'capplets/windows/Makefile.am')
-rw-r--r--capplets/windows/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/capplets/windows/Makefile.am b/capplets/windows/Makefile.am
index 63f75fbb..92175d2c 100644
--- a/capplets/windows/Makefile.am
+++ b/capplets/windows/Makefile.am
@@ -10,12 +10,13 @@ mate_window_properties_SOURCES = \
mate-metacity-support.c \
mate-window-properties.c
-@INTLTOOL_DESKTOP_RULE@
-
desktopdir = $(datadir)/applications
Desktop_in_files = mate-window-properties.desktop.in
desktop_DATA = $(Desktop_in_files:.desktop.in=.desktop)
+$(desktop_DATA): $(Desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
AM_CPPFLAGS = $(MATECC_CAPPLETS_CFLAGS) \
-DUIDIR=\""$(uidir)"\" \
-DPIXMAPDIR=\""$(pixmapdir)"\"