summaryrefslogtreecommitdiff
path: root/typing-break/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'typing-break/meson.build')
-rw-r--r--typing-break/meson.build57
1 files changed, 57 insertions, 0 deletions
diff --git a/typing-break/meson.build b/typing-break/meson.build
new file mode 100644
index 00000000..29033b95
--- /dev/null
+++ b/typing-break/meson.build
@@ -0,0 +1,57 @@
+cflags = [
+ '-DIMAGEDIR="@0@"'.format(mcc_directorydir),
+ '-DMATELOCALEDIR="@0@"'.format(mcc_pixmaps),
+]
+
+deps = [
+ gtk_dep,
+ glib_dep,
+ mate_desktop_dep,
+ x11_dep,
+ xext_dep,
+ xscrnsaver_dep,
+ m_dep
+]
+deps += [appindicator_dep,ayatana_dep]
+executable(
+ 'mate-typing-monitor',
+ sources : [
+ 'drw-break-window.c',
+ 'drw-monitor.c',
+ 'drwright.c',
+ 'drw-selection.c',
+ 'drw-timer.c',
+ 'drw-utils.c',
+ 'main.c'
+ ],
+ include_directories : config_inc,
+ dependencies : deps,
+ c_args : cflags,
+ install : true,
+ install_dir : get_option('bindir')
+)
+
+install_data(
+ 'mate-typing-monitor.png',
+ install_dir: join_paths(mcc_icondir, 'hicolor', '48x48', 'apps')
+)
+
+install_data(
+ 'mate-typing-monitor.svg',
+ install_dir: join_paths(mcc_icondir, 'hicolor', 'scalable', 'apps')
+)
+
+icons = [
+ 'bar-disabled.png',
+ 'bar-green.png',
+ 'bar.png',
+ 'bar-red.png',
+ 'ocean-stripes.png'
+]
+
+foreach icon: icons
+ install_data(
+ icon,
+ install_dir : mcc_pixmaps
+ )
+endforeach