summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-08-24 17:38:41 +0200
committerinfirit <[email protected]>2015-08-24 17:41:03 +0200
commit18b5bf62a216e250d2f5292b1a7b145f221ef666 (patch)
tree72ad056a16415550e9ba66fdaf3ba6881b46acf7 /configure.ac
parentf23b13a8d55c2cb8d2e693453a3298506f7f08ee (diff)
downloadmate-desktop-18b5bf62a216e250d2f5292b1a7b145f221ef666.tar.bz2
mate-desktop-18b5bf62a216e250d2f5292b1a7b145f221ef666.tar.xz
Define max/min version of GLib
This warns us of using symbols like g_assert_null not available in GLib 2.36
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c71eb46..7a2891a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,12 @@ if test "x$enable_deprecation_flags" = "xyes"; then
AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
fi
+# GLib min/max required versions
+AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs added after GLib 2.36])
+AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs deprecated before GLib 2.36])
+
# Should we build mate-about? Useful for people who need to build
# two mate-desktop using two different versions of GTK+
AC_ARG_ENABLE([mate-about],