summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <[email protected]>2016-06-26 12:18:28 +0200
committerraveit65 <[email protected]>2020-01-09 00:06:04 +0100
commite9884b43e1643d1e751a5cb03f653fcd00e585e4 (patch)
treed3677ad6112e89ecc87adb47ce80540fe7543423 /configure.ac
parent298af2236e8f23064f00b03bedc7780a6456a5bf (diff)
downloadmate-desktop-e9884b43e1643d1e751a5cb03f653fcd00e585e4.tar.bz2
mate-desktop-e9884b43e1643d1e751a5cb03f653fcd00e585e4.tar.xz
thumbnail: Always use external gdk-pixbuf thumbnailer
Instead of special-casing gdk-pixbuf-supported image formats, use an external thumbnailer. This will give us the ability to: - cancel running thumbnail operations - avoid memory leaks, buffer overflows, double-frees, etc. in the image loaders having an impact on the application - limit resource usage when thumbnailing https://bugzilla.gnome.org/show_bug.cgi?id=768064 origin commit: https://gitlab.gnome.org/GNOME/gnome-desktop/commit/b69fde6 https://gitlab.gnome.org/GNOME/gnome-desktop/commit/dba6d95
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8d5ef38..5e17d20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,6 +98,7 @@ else
EXTERNAL_PNP_IDS="$with_pnp_ids_path"
fi
+GDK_PIXBUF_REQUIRED=2.36.1
GLIB_REQUIRED=2.50.0
GIO_REQUIRED=2.26.0
GTK_REQUIRED=3.22.0
@@ -189,7 +190,7 @@ AC_SUBST(RANDR_PACKAGE)
dnl pkg-config dependency checks
-PKG_CHECK_MODULES(MATE_DESKTOP, gdk-pixbuf-2.0 gtk+-3.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GIO_REQUIRED $STARTUP_NOTIFICATION_PACKAGE $RANDR_PACKAGE iso-codes)
+PKG_CHECK_MODULES(MATE_DESKTOP, gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED gtk+-3.0 >= $GTK_REQUIRED glib-2.0 >= $GLIB_REQUIRED gio-2.0 >= $GIO_REQUIRED $STARTUP_NOTIFICATION_PACKAGE $RANDR_PACKAGE iso-codes)
ISO_CODES_PREFIX=$($PKG_CONFIG --variable prefix iso-codes)
AC_SUBST(ISO_CODES_PREFIX)