summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorzhuyaliang <[email protected]>2023-09-04 14:54:56 +0800
committerLuke from DC <[email protected]>2023-10-08 06:56:22 +0000
commita8e5c19f5a6c4632dc5b72d0eea38f5d09d35e19 (patch)
tree7b69cddf028c986fac77d952e70b37d883c0122d /meson.build
parentb7b0241a59d616699d83b03c57227182e8b1109a (diff)
downloadmate-desktop-a8e5c19f5a6c4632dc5b72d0eea38f5d09d35e19.tar.bz2
mate-desktop-a8e5c19f5a6c4632dc5b72d0eea38f5d09d35e19.tar.xz
Add meson build libstartup-notification support type is auto
Fix https://github.com/mate-desktop/mate-desktop/issues/570
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 83e6de5..e9844c9 100644
--- a/meson.build
+++ b/meson.build
@@ -76,17 +76,19 @@ randr_dep = dependency('xrandr', version: '>= 1.3', required: false)
config_h.set('HAVE_RANDR', randr_dep.found())
iso_codes = dependency('iso-codes')
iso_codes_prefix = iso_codes.get_pkgconfig_variable('prefix')
+libstartup_dep = dependency('libstartup-notification-1.0', version: '>= 0.5',
+ required: enable_startup_notification )
libmdt_dep = [
dependency('gdk-pixbuf-2.0'),
dependency('gobject-2.0'),
dependency('glib-2.0', version: '>= 2.50.0'),
dependency('gio-2.0', version: '>= 2.26.0'),
- dependency('libstartup-notification-1.0', version: '>= 0.5',
- required: enable_startup_notification ),
+ libstartup_dep,
randr_dep,
iso_codes,
]
+config_h.set('HAVE_STARTUP_NOTIFICATION', libstartup_dep.found())
gnome = import('gnome')
i18n = import('i18n')
pkg = import('pkgconfig')