summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2014-05-11 12:14:15 +0200
committerStefano Karapetsas <[email protected]>2014-05-11 12:14:15 +0200
commitd80a75c3b9b4d453067386c6a8f3cc7506c0a401 (patch)
tree5a77db621958dae281fc27466f5440d4e8acb98e /tools/Makefile.am
parent820fb82ac033b7cbecf2b16cd3b7185d3b8957af (diff)
downloadmate-desktop-d80a75c3b9b4d453067386c6a8f3cc7506c0a401.tar.bz2
mate-desktop-d80a75c3b9b4d453067386c6a8f3cc7506c0a401.tar.xz
Add MATE Color Selection tool
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index ccce500..906694b 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,11 +1,24 @@
+bin_PROGRAMS = mate-color-select
bin_SCRIPTS = mate-gsettings-toggle
-if MATE_CONF_IMPORT_ENABLED
+mate_color_select_SOURCES = \
+ mate-color-select.c
+
+mate_color_select_CFLAGS = \
+ -DLOCALE_DIR=\"$(datadir)/locale\" \
+ $(MATE_DESKTOP_CFLAGS)
+
+mate_color_select_LDADD = \
+ $(top_builddir)/libmate-desktop/libmate-desktop-2.la \
+ $(MATE_DESKTOP_LIBS)
+
@INTLTOOL_DESKTOP_RULE@
desktopdir = $(datadir)/applications
-desktop_in_files = mate-conf-import.desktop.in
+desktop_in_files = mate-color-select.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+if MATE_CONF_IMPORT_ENABLED
+desktop_in_files += mate-conf-import.desktop.in
bin_SCRIPTS += mate-conf-import
endif
@@ -14,8 +27,9 @@ bin_SCRIPTS += mpaste
endif
EXTRA_DIST = \
+ mate-conf-import.desktop.in.in \
mate-conf-import \
mate-gsettings-toggle \
mpaste
-CLEANFILES = mate-conf-import.desktop mate-conf-import.desktop.in
+CLEANFILES = *.desktop *.desktop.in