summaryrefslogtreecommitdiff
path: root/mate-about/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'mate-about/meson.build')
-rw-r--r--mate-about/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/mate-about/meson.build b/mate-about/meson.build
index 0ef8318..3d25310 100644
--- a/mate-about/meson.build
+++ b/mate-about/meson.build
@@ -1,5 +1,6 @@
date_exe = find_program('date')
mate_date = run_command(date_exe, '+%Y-%m-%d').stdout().strip()
+mate_year = run_command(date_exe, '+%Y').stdout().strip()
mate_data = configuration_data()
@@ -10,6 +11,9 @@ mate_data.set('MATE_PLATFORM', mate_platform)
mate_data.set('MATE_MINOR', mate_minor)
mate_data.set('MATE_MICRO', mate_micro)
+mate_about_data = configuration_data()
+mate_about_data.set('RELEASE_YEAR', mate_year)
+
executable('mate-about',
'mate-about.c',
c_args: [
@@ -37,3 +41,10 @@ mate_version_xml_in = configure_file(
install: true,
install_dir: join_paths(get_option('datadir'), 'mate-about'),
)
+
+mate_about_h_in = configure_file(
+ input: 'mate-about.h.in',
+ output: 'mate-about.h',
+ configuration: mate_about_data,
+ install: false,
+)