summaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorMichal Ratajsky <[email protected]>2014-11-10 10:22:29 +0100
committerMichal Ratajsky <[email protected]>2014-11-10 10:22:29 +0100
commitb70459bd7ab6cbf64892fbaea6a931a80f0cc132 (patch)
tree488768eb7c736d014f29e08e7191323e2fcfa93a /data/icons/Makefile.am
parentcf4eac60cdc4d02fdeccb3b85d524eda8a5f320e (diff)
parent194e26e0be4660dae0987445c0edcfa8349fde51 (diff)
downloadmate-media-b70459bd7ab6cbf64892fbaea6a931a80f0cc132.tar.bz2
mate-media-b70459bd7ab6cbf64892fbaea6a931a80f0cc132.tar.xz
Merge branch 'michal-wip'
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..119338b
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,24 @@
+NULL =
+
+SUBDIRS = \
+ scalable \
+ 16x16 \
+ 22x22 \
+ 24x24 \
+ 32x32 \
+ $(NULL)
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/mate
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+-include $(top_srcdir)/git.mk