summaryrefslogtreecommitdiff
path: root/data/sounds/meson.build
diff options
context:
space:
mode:
authorzhuyaliang <[email protected]>2023-10-26 20:56:27 +0800
committerraveit65 <[email protected]>2023-11-30 20:17:06 +0100
commit7f45b836192f42d246fe9709205244e675adea0a (patch)
tree6ea428dac42f4b87a0687f0593aeacb7761faa2e /data/sounds/meson.build
parentf4a3f423d378c2c4b16a22fa7382e7a94932dd57 (diff)
downloadmate-media-7f45b836192f42d246fe9709205244e675adea0a.tar.bz2
mate-media-7f45b836192f42d246fe9709205244e675adea0a.tar.xz
add meson build support
Diffstat (limited to 'data/sounds/meson.build')
-rw-r--r--data/sounds/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/data/sounds/meson.build b/data/sounds/meson.build
new file mode 100644
index 0000000..329c4b7
--- /dev/null
+++ b/data/sounds/meson.build
@@ -0,0 +1,29 @@
+xml_data = configuration_data()
+xml_data.set('datadir', mm_datadir)
+xml_in_file = configure_file(
+ input : 'mate-sounds-default.xml.in.in',
+ output : 'mate-sounds-default.xml.in',
+ configuration : xml_data
+)
+
+i18n.merge_file(
+ input: xml_in_file,
+ output: 'mate-sounds-default.xml',
+ po_dir: po_dir,
+ data_dirs: its_dir,
+ install: true,
+ install_dir: join_paths(mm_pkgdatadir, 'sounds')
+)
+
+oggs = [
+ 'bark.ogg',
+ 'drip.ogg',
+ 'glass.ogg',
+ 'sonar.ogg'
+]
+foreach ogg: oggs
+ install_data(
+ ogg,
+ install_dir: join_paths(mm_datadir, 'sounds', 'mate', 'default', 'alerts')
+ )
+endforeach