summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e0ba96b..20a7288 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,7 @@ NULL =
SUBDIRS = po data man mate-volume-control
DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-compile-warnings=no \
CFLAGS='-Wno-deprecated-declarations'
DIST_SUBDIRS = \
@@ -23,6 +24,18 @@ EXTRA_DIST = \
its \
$(NULL)
+# Distribute the Meson build system files as well
+EXTRA_DIST += \
+ meson.build \
+ meson_options.txt \
+ build-aux/meson_post_install.sh \
+ data/meson.build \
+ data/icons/meson.build \
+ data/sounds/meson.build \
+ man/meson.build \
+ mate-volume-control/meson.build \
+ po/meson.build
+
DISTCLEANFILES = \
mate-volume-control/org.mate.applets.GvcApplet.mate-panel-applet \
mate-volume-control/org.mate.panel.applet.GvcAppletFactory.service \