summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-10-17 09:57:58 +0200
committerraveit65 <[email protected]>2021-10-26 13:59:06 +0200
commit0af959c26303eda2f7e16f938b4d9c6d2df2007e (patch)
tree333911e52020ccc6d1015da47bab0c89fef3192d /configure.ac
parentf9416ad74a962fda5bee70280a8a5bc5912ef01b (diff)
downloadmate-menus-0af959c26303eda2f7e16f938b4d9c6d2df2007e.tar.bz2
mate-menus-0af959c26303eda2f7e16f938b4d9c6d2df2007e.tar.xz
Let user disable collection menu entry [--disable-collection]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a41e815..6448195 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,15 @@ PKG_CHECK_MODULES(GIO_UNIX, gio-unix-2.0 >= 2.50.0)
AC_SUBST(GIO_UNIX_CFLAGS)
AC_SUBST(GIO_UNIX_LIBS)
+AC_ARG_ENABLE(collection,
+ AC_HELP_STRING([--enable-collection],
+ [enable collection menu entry]),,
+ enable_collection=yes)
+
+if test x$enable_collection = xyes; then
+ AC_DEFINE(WITH_COLLECTION,1,[Build with collection menu entry support])
+fi
+
AC_ARG_ENABLE(deprecation_flags,
[AC_HELP_STRING([--enable-deprecation-flags],
[use *_DISABLE_DEPRECATED flags @<:@default=no@:>@])],,
@@ -102,6 +111,7 @@ echo "
Use *_DISABLE_DEPRECATED: ${enable_deprecation_flags}
Turn on debugging: ${ax_enable_debug}
+ Collection menu entry: ${enable_collection}
Build introspection support: ${found_introspection}
Native Language support: ${USE_NLS}