summaryrefslogtreecommitdiff
path: root/po/meson.build
diff options
context:
space:
mode:
authorXiaotian Wu <[email protected]>2023-01-08 11:51:53 +0800
committerraveit65 <[email protected]>2023-09-02 17:12:19 +0200
commitd5e498eacbd3ec8c144e302d3ee0309d437d6e5f (patch)
tree28bfd57eaac5375b12af29a53f8007011e2fe5a7 /po/meson.build
parent5e3658eb0b2428a49b47d56300fec73f74f70f4f (diff)
downloadmate-menus-d5e498eacbd3ec8c144e302d3ee0309d437d6e5f.tar.bz2
mate-menus-d5e498eacbd3ec8c144e302d3ee0309d437d6e5f.tar.xz
add meson build system
After switching to meson, calling the `g-ir-scanner` command with the `--warn-all` parameter in the generated `build.ninja` file will display these warnings: ``` Warning: MateMenu: symbol="DesktopEntryType": unknown namespace for identifier "DesktopEntryType" Warning: MateMenu: symbol='desktop_entry_new': Unknown namespace for symbol 'desktop_entry_new' Warning: MateMenu: symbol='EntryDirectory': Unknown namespace for identifier 'EntryDirectory' ``` The reason for these warnings is that we use `MateMenu` as `identifier_prefix` and `matemenu` as `symbol_prefix`, but the symbols that report warnings do not start with these prefixes.
Diffstat (limited to 'po/meson.build')
-rw-r--r--po/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/po/meson.build b/po/meson.build
new file mode 100644
index 0000000..7e2b19f
--- /dev/null
+++ b/po/meson.build
@@ -0,0 +1,2 @@
+i18n = import('i18n')
+i18n.gettext(meson.project_name(), preset: 'glib',)